iPad Pro - No visual images [Solved - Updated iPad App]


I have a new 12.9” iPad Pro that I want to use as my remote. All my information from my MacBook Pro is showing, but all visuals of album covers, artist images, etc. is missing.

Using my small older mini-iPad I have none of this issue, everything is there the same as if I was using the “core”. I believe I read elsewhere you’ve had similar complaints about the new iPad Pro… is there a solution?


Hi Alex, Thanks for this suggestion. I have been through Settings and can’t find an option for forcing Roon to rescan all files. Any further guidance? Thanks very much.

Hi Doug,

Can you delete the Roon iPad app, reboot the iPad and then reinstall? See if that helps.

Cheers, Greg

1 Like

Thanks so much Greg… exactly right! I’ve got it up and fully visual on my iPad now.
Way cool…!


1 Like

Hi, This is my second time posting this unsolved problem. I have a new 12.9" iPad Pro, and using my MacBook Pro as my core I am unable to get album art or images to come up using the iPad Pro as an extension of Roon. Previously I was instructed to erase Roon from the iPad and reload it, which temporarily helped displaying some of the Roon site, but not all, and it has again stopped. The curious thing is an old iPad mini functions perfectly with my set-up.

Thanks, Doug

What iOS version is on the new iPad?

Hi sorry for the delay in responding. My Ipad OS version is 11.4.1. I bought this unit new in June.

@support, I have not generated a solution to my posting to the R. community.

New 12.9" iPad Pro running OS 11.4.1 with no Roon or album art images,
even after deleting and re-installing Roon on the iPad.
(Curiously I have a much older mini-IPad that runs Roon perfectly with all images intact)

My core is MacBook Pro with OS 10.13.6 >UltraRendu>Eastern Electric MiniMax Supreme DAC>
Oknyo P3000R>Oknyo M5000> Focal Chorus 726.

Any suggestions for the iPad Pro? I invested in it to run Roon from my core.

Thanks, Doug


Can you please let me know what version of Roon you’re running on the iPad? You can find out this information in Roon Settings -> About. The latest version we have is Version 1.5 (build 354), I would double check that you have updated to the most recent Roon version as the first troubleshooting step here.

I would also make sure that the iPad has some free space on it to download those images, you can check this information in iOS Settings -> General -> iPad Storage. Please let me know if my suggestions help.


Noris, I’ve been working at this off and on all day. I need to update the OS on the iPad, it was not current. Then I reloaded Roon Remote. Now all images are present and the problem is solved. Thanks for nudging the OS update, that seems to have solved the problem.


1 Like

Happy to help @Doug_West! Thanks again for contacting support and hope you have a great day.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.