iPad Remote Working But Outputs Audio to Wrong device

I am using the current version of Roon on a Mac Mini running OS 10.12.5.

I am able to control every Roon function I’ve tried on my iPad remote except the audio output. Instead, audio output is being directed to Mac Mini’s internal speaker.

The Roon Audio settings on my iPad are idential to those of Roon on the Mac Mini

iPad is control only. You will not get it to produce audio via Roon without 3rd party software that isn’t free. Ipeng 9.3 from memory?

I don’t understand your reply.

Just to be clear: I am not attempting to play music thru my iPad. I am only attempting to use the iPad to play music through my big-rig’s speakers

How have you connected the Mac Mini to your system? Does it work as you expect when you use the Mini to control the system?

Have you chosen your big rig zone on the iPad? If the zone isn’t visible to the iPad have you accidentally made it a private zone?

Still having this problem. On my iPad, Roon displays “MSB USB Audio” in the footer, which is where I want the output to go. However, the Signal Path displays Source -> Mac Mini (which is where Roon is running and where music is playing uner remote control) —> Output: OS Mixer

@support this is just a config issue as far as I can tell but someone with a Mac needs to talk him through what to do?

1 Like

Hi Leroy,
Can you upload a screenshot of your Settings/Audio page ? Use the up arrow in the post editor to attach a acreenshot into your post.

Hi @LEROY_SCHWARZ — Touching base with you here to see how things are going. If you can upload a screenshot of your “settings/audio page”, as suggested by @andybob I am sure we can figure out what is going on here.

Looking forward to your feedback!

BOTH my mac mini and iPad display the very same settings

You will need to give the two enabled outputs different names, so you’ll be able to select them individually. Rename System Output to well eh… System Output (or something a bit more creative) – and you’ll be able to choose between that one and the MSB by clicking on the Zone icon (little speaker bottom right) on any remote, including your iPad.


Many thanks for attempting to help, but, sadly, I am ignorant about how to do what you suggest.

I juat attempted to read the section on Zones in the User Guide, twice; but, well, without criticizing whoever wrote it, I find quantum mechanics much easier to read and understand, including superposition and entanglement.

Would you please spell out what I should do and how I should do it? I understand in a audio system with many rooms and speaker systems involved that it is necessary to inform Roon what device is controlling Roon and what room/speakers the music should be playing from. Hence, I understand that I need to inform Roon that either my iPad or my desktop is controlling Roon; and, regardless, I want the music to play from the same set of speakers. Without doing anything I can get the remote to take control of Roon, but, sadly, the music is coming from my Mac Mini’s speaker.

Have you read this page yet?

I think the issue here is that the System Output zone has been renamed to MSB USB Audio – you’ll want to set that back to System Output or something similar here:

And you should be in good shape. And if not, just let us know @LEROY_SCHWARZ!

Under iPad control the audio continues to come out of the Mac Mini’s speaker. Images below:

Disable System Output. It doesn’t need to be active. Make the USB device the only active device and make sure you are in exclusive mode.

I did as you recommended. In Audio Settings both System Output and Built-in Outpur display “Enable”. The MSB USB Audio 2.0 Output displays that name in the Zone Name Box. No other changes to screen shot above.

I have verified that it is in Exclusive mode.

My desktop displays MSB USB Audio 2.0 Output in the footer.

My iPad displays “No Audio Devices Found” and “Manage Audio Devices”

Please advise

If your iPad doesn’t see the zone on the Mac it might have been configured as private by mistake. Double check that.

Hi @LEROY_SCHWARZ ---- Thank you for the continued feedback. In an attempt to try and help with this current situation, I configured an almost identical setup to yours to try and alleviate any potential confusion. Please see below.

My setup:
Core = Macbook Air
Roon Remote = Nexus 6P
Endpoint = PS Audio Perfect Wave directly mounted to the MBA via USB.

Here is my “audio” tab on the MacBook Air and my Android remote (see below). As you can see, I have all other outputs “disabled”, except for the attached PS Audio device.



When the PerfectWave zone is “active” and selected, as you have noted, it appears at the bottom of Roon’s display



Now, say I were to make the Perfect Wave a “private zone” on my core machine. I will not be able to access it from my phone. As seen below.

(Path: “settings” - > “audio” - > select the gear next to the desired zone (in my case the perfect wave, in your case the MSB) - > “device setup” - > “General”)



Notice how the zone is still listed but I am unable to select via “Manage audio devices”? Can you please confirm that you currently do not have the MSB DAC setup as a “private zone”.