iPad Roon App not loading artwork

Roon Core Machine -
iMac (27-inch, Late 2012)
3.4 GHz Intel Core i7
32 GB 1600 MHz DDR3
NVIDIA GeForce GTX 680MX 2048 MB

Telsra Smart Modem Dual band Wi-Fi 802.11n (NBN)
Over WiFi (in apartment)

Arcam SA30
Apple TV 4k (Gen 1)
iPad Generation 7 (Latest Firmware - 15.4.1)

Tidal (until recently - see below)
400G of Ripped Flac Files stored on Roon core (iMac)

Issues:

1/ The Roon Remote App via my iPad will not load albums artwork via my Flac Library from my core (iMac) nor Tidal. Track will play via my SA30 (preferred device) but I am not getting the artwork and information I am paying for via the app. The experience is frustrating, non-emersive, and has caused me to stop using it. My Phone (iPhone 10 Max Pro) works fine so i don’t understand why it is not working.

2/ Tracks have been skipping both from my library and via Tidal which is extremely frustrating.

3/ Have cancelled Tidal - Cancelled due to tracks jumping and skipping intermittently via Roon. The only reason I subscribed to Tidal is due to my Roon subscription.

My expectations:

A - You can fix the issues I have been experiencing and reset my account (you will see that I have hardly used the software due to it being so glitchy) so that I can experience what I paid for.

B - If you cannot fix the above mentioned issues I would like a refund.

I specifically bought my Arcam SA30 because it was Roon ready and have heard so many good things about your software. I just want to enjoy it to its fullest as I love music. As far as i know, I have the correct hardware but a at a loss as to why the software will not work properly.

Please help,

Frustrated yet hopeful user
Luke





1 Like

@Luke_Mair1 welcome Luke!

On your iOS devices can you turn off the beta feature “prevent cross site tracking “ and “ hide IP address “ .

Both these features can be slightly problematic.

1 Like

Also are not the core and remote updates to the latest b923 release

1 Like

Thanks Andy, I gave this a go but it still hasn’t resolved the artwork problem. Functionally it ‘works’ but no artwork or detailed artist information is displaying. I appreciate you help mate (apologies for the delayed reply)

Mate, I have the most up to date version but I am still having issues with any artwork or detail artist info loading. It works via my Phone (iPhone X Pro) which is interesting but I need the iPad.

Thanks again for your help - any more suggestions ?

My best guess is the WiFi is the main issue.
There have been a few recent threads with missing artwork due to network issues.
Also intermittent playback on streaming services is usually another sign of network related issues.

Is there any chance you can connect the Core by Ethernet cable?

1 Like

Hmmm …
Unfortunately I don’t have the option for a wired connection at present so I can’t really test that…
I don’t have any problems with streaming or downloading Large 4K files or any other issues with internet otherwise though. My iMac shows all of the information perfectly too (without wired connection).

Please excuse my lack of knowledge or ignorance, but how would a core connected via Ethernet effect artwork being displayed on an iPad given the internet is performing fine for high definition video streaming etc ??

Thanks Hammer

bandwitdh on wifi is a one way street with constant delays…lan is like a 6 lane freeway

1 Like

Unfortunately Roon is a lot more bandwidth intensive and demanding than the vast majority of other on the fly streaming apps or services including 4K video.

It is also possible that there is something blocking the artwork portion getting through the network.
There are a few threads on this very matter fairly recently.

Possibly not useful for a solution but there may be something of interest in this thread

So just to clarify, if my core (iMac) is running via Ethernet connection, the bandwidth required for my Roon remote using my iPad over wi-fi should be more freed up to be able to show the full artwork and artist information ?

If so I may run a Lind Ethernet cable to my iMac to test this :+1:t3: Please correct me if I’m wrong

Thanks again mate

Yes correct. This will lessen the two way load on the wifi

1 Like

Thankoyu mate, I will give this a shot and let you know how I go

Make sure the network interface is the priority interface order to WiFi in network prefs or turn off the WiFi when it’s on Ethernet