iPhone 12, Roon Remote - no audio connected to iFi Gryphon when switching albums

Roon Core Machine

Roon Server: version: 2.0 build 1148
Roon ROCK - installed on a HP Prodesk 600 G2 Desktop mini
Roon local Library is on a NAS, DS214Play.
Roon Remote on Iphone 12, version 2.0 build 1148.

Networking Gear & Setup Details

Internal network through wi-fi (very close to the router, no wi-fi issues)
Modem in Bridge mode, connected to a router: Netgear RT-AC87U
NAS Synology DS214Play, connected to the router
iPhone 12, iOS version 16.1

Connected Audio Devices

iPhone 12, iOS version 16.1, wired connection to:
iFi xDSD Gryphon :Latest firmware installed, version 1.61-1

Number of Tracks in Library

Roon local Library is on a NAS, DS214Play. 4021 tracks imported.

  • Qobuz tracks (1200)

Description of Issue

Intermittent Audio outages after switching to another album, followed by crash on iPhone Roon Remote when unplugging cable connection. This happens only when switching from one album to another, so probably bitrate change (assumption).

Steps to reproduce (unfortunately only intermittently, I can’t seem to find an ‘always fails’ situation):

  1. Play a song on one album - Audio is fine
  2. Play another song on another album - Audio is fine.
  3. As 2
  4. As 3

  5. As previous. In the interface, it appears the album (song) is playing, but all of a sudden, no audio. After about 10 seconds, it automatically skips to the next song, but still no audio. Choosing any other song (manually) to play from then on fails to produce sound (even though the song appears to be playing in the interface).
  6. Unplug cable connection from iPhone. Expected behavior here would be that the song continues playing on the iPhone itself, with audio coming from the iPhone. Instead, the app crashes and becomes unresponsive to user actions.

As for step 6: when unplugging cable connection without the occurence of step 5, expected behavior is fine, i.e. the song continues playing on the iPhone itself with audio coming from the iPhone.

Troubleshooting so far:

  • Uninstalled / re-installed Roon Remote app on the iPhone. Only setting changed is enabling the iPhone as a player in Settings → Audio, to keep settings as ‘clean’ as possible. No fix.
  • Rebooted Roon ROCK. No fix.
  • Tried the exact same setup on an iPad mini (so basically just unplug the iphone and plug in the iPad Mini). Everything works fine on the iPad, no Audio outages / crashes. This rules out any cable issues, Roon Server problems, iFi Gryphon issues, Networking issues, etc.
  • Skipping to another song on the same album always works fine.
  • I disabled “Volume Sync” on the iFi Gryphon to rule that out as an issue.
  • Only closing the iPhone Roon Remote app and re-opening it makes the app play music again. (It’s not necessary to power off/on the iFi Gryphon).

Things I don’t know / haven’t found out (yet):

  • Does the problem occur when switching albums which are in my local Library on my NAS, or does it happen only when streaming from Qobuz?

I think I’ve figured this one out myself. :wink:
The iPhone is connected to the iFi xDSD Gryphon with a short usb-c to lightning OTG cable (included with the Gryphon). I am using a usb-c extension cable (female one side, male another) of 1 metre.

The latter is the problem. Leaving this extension out, so exclusively using the usb-c to lightning OTG cable, appears to have fixed the issue. Strangely enough, my iPad doesn’t have a problem at all with the extension cable. So it appears the digital output signal of the iPhone is somewhat weak or… at least different (compared to the iPad).

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.