iPhone 7 Plus Waiting for Remote Core

I continually receive this error on my iPhone 7 Plus, but not my iPad. My MacBook Pro connects instantly. The RAAT server is fixed IP on the same network. It’s only my iPhone.

Any tips?

Let’s check the obvious first: is your iPhone connected to WiFi and if so – to the same network your iPad is?

Yes, same network. Same subnet.

Is Wi-fi Assist turned on? Turn it off and see if that helps.

You can find it at the bottom of Cellular page in Settings.

Have you tried deleting the app and reinstalling it?

I tried this to no avail.

I also tried this, and it did not work.

I am assuming you have rebooted the core? If so I guess support will have to get involved.

Trying now …

Try reseting your iPhone’s Network settings. It will require you to rejoin your networks but might help.

I did this as well as rebooting the server and my iPhone. Still “Searching for devices …”

If networking reset doesn’t work try reinstall the app but make sure to turn the iCloud backup off for Roon first or it will restore your settings.

I deleted and re-installed the app. I forced a manual DNS server, and that did not work either.

Did you turn off iCloud backup first, if you don’t it could restore corrupt settings.

iCloud backup is turned off.

Which iPhone and which iPad? Network topology? Managed switches? Router? Wifi configuration?

@support will want details.


iPhone 7 Plus, latest iOS 11.2.1.

Network is Netgear Orbi setup (one router, two satellites), all devices are on the same 192.168.x.x IP range with subnet mask.

** Update **

It’s working now. I went to the gas station up the street with my phone and came home and now it works.

I was unable to ping the phone from the server, but now it pings and connects. Strange.

Chris, do you mean that your phone doesn’t connect to our core at all, or there is a delay in comparison to your MacBook.

I ask because I have an iPhone 7 Plus and an Orbi Network with two satellites, just like you.

Roon 1.3 was very slow to connect on my iPhone. Roon 1.4 does so much more quickly, but not instantaneous. Often, it still takes 5-10 seconds, and if the phone screen sleeps or I go to a different app and return, I have to wait for Roon to wake up for a similar time period.

My point may be that this is the best that Roon can do on an iPhone 7 Plus in an Orbi networked environment.

Of course, I too would enjoy instantaneous and no wait for a refresh if the screen sleeps or I look at a different app. :slight_smile: JCR

When it does connect, it does take a few seconds as you mentioned, while my MacBook Pro connects instantly.