iPhone App crashing repeatedly

Roon Core Machine

Barebones Case/MB model: shuttle XH110
Processor Intel(R) Core™ i5-7400 CPU @ 3.00GHz 3.00 GHz
Installed RAM 8.00 GB (7.89 GB usable)
System type 64-bit operating system, x64-based processor
Edition Windows 10 Pro
Version 21H1
Installed on ‎11/‎15/‎2020
OS build 19043.1826
Experience Windows Feature Experience Pack 120.2212.4180.0

Networking Gear & Setup Details

Orbi Pro SXK80
Core PC connects through gigabit wired Ethernet

Connected Audio Devices

NAD c658
Bluesound Node 2i, Vault 2i, Powernode
Multiple RPi Roon Bridge devices (mostly DAC HATs, but one USB DAC)
Occasionally AirPlay and Chromecast devices

Number of Tracks in Library

27,000 tracks

Description of Issue

Roon iPhone app crashes about 15 seconds after it’s opened. Or it appears to crash. It seems to keep running in the background, and can be resumed by swiping up from the bottom to get the app switching menu, but it just vanishes from the screen while using it. No particular pattern to the actions that lead up to the crash. It happens about 15 seconds after opening/resuming, even if I don’t touch it. Music keeps playing, so the core and endpoints are unaffected when it happens.

I’ve tried restarting the phone, restarting the core, deleting the app and re-installing. That seemed to help for a bit, but the behavior has returned.

IPhone 13 Pro Max
iOS 15.6.1
App version 1.8.01021

Hi @Andy_Spinks,

I’m sorry to hear you’ve had issues. I enabled remote diagnostics on your core and did some investigating.

I see that your iPhone keeps losing its connection to your core. It doesn’t tell us why though. Can you please ensure that both your core software and iPhone Roon Remote app are up to date? Those two being out of sync can cause a problem. You might also be sure that the iPhone is connected to the same wi-fi network that the core is hard-wired to. Let me know and I will try to provide the next steps if this doesn’t change things for you.


Thanks, @Wes! The strangest thing is happening today. I pulled up Settings on the Roon app to check the software version (phone and core are both on Build 1021), but it didn’t crash right away. I logged in to the router to confirm it had the latest firmware (it did), then I switched to the Remote Desktop App to log in to the server. A manual update check found a few small Windows updates, which I installed. It didn’t ask me to reboot, but I went ahead and did it anyway. After rebooting the core, I opened Roon and started trying to play music on my NAD c658. Strangely, Roon couldn’t turn the NAD on. I tried several times. It wouldn’t play, but on the other hand, the app didn’t crash either. I verified that the BluOS app can make the NAD play, and Roon can play to my other Bluesound devices. Just not Roon to tbe NAD.


Hi @Andy_Spinks,

A couple of things you can try. Restart the NAD and restart your core to see if something changes. If you would, please take note of the date/time you try to enable the NAD so I can look at remote diagnostics and see what’s happening assuming the issue persists.


Hi @Wes,
Good news and bad news: Fortunately Roon is again controlling the NAD as it should, but unfortunately the iOS crash is back.

I’ve rebooted a couple of times, but only this morning did I get enough time to test it immediately after rebooting. For log cross-comparison purposes:

11:37am: reboot core

11:38am-11:40am: confirmed core status by opening iOS app. (Crashed at least once)

11:40am-11:44am: unplugged NAD from power, plugged back in, powered up, and played from BluOS app. Paused, then started playback from Roon app (crashed at least once)

One thing I noticed that I didn’t see last time: After it crashes, if I switch to a different app before switching back to Roon, the Roon preview has this error:

“Uh oh, something’s not right.
Make sure your Roon Core is turned on [and] you’re connected to the same network.
Select a different Core”

Looking closer at the iPhone’s network connection, it’s connected to the Wi-Fi mesh system through the Orbi pro SXS80 satellite. The router says the connection is “fair” but the iPhone is showing full bars on Wi-Fi. Speedtest results show a blazing fast connection, but jitter is 7ms. Not sure if that matters for this. Are there any router or phone wifi settings I should check?


That’s actually a really nice wifi connection there. Fiber is nice!

Ok, this is hard to do with your device crashing but let’s try to get your iPhone’s image cache cleared. You’ll have to be fast but go to settings>setup> and click clear cache. Close Roon fully and restart it. If this doesn’t work we will have additional steps for you so keep me posted please!


Hey @Wes, I think clearing that image cache fixed it! Seems pretty stable the last few days. Now I guess I’m ready for 2.0! :sweat_smile:

1 Like

So glad to hear this! We’re certainly excited to roll out new features and look forward to enjoying the music with you!


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.