Iphone app minimizes as soon as it connects to server

Core Machine (Operating system/System info/Roon build number)

Imac late 2019, OS X 10.15.7 Catalina Roon Version 1.7(build 777)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Local wifi

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)


Description Of Issue

On the iPhone Roon remote app starts fine looking for Remote Core, once the core is started or selected the remote app crashes(or goes to the background), if I close the Core the app notices and the dialog is back.
I am trying Roon for the next two weeks, so it is important for me to solve this issue before the trial is over if I am to purchase.

The issue is with Iphone only as my iPad works perfectly.

Hi @John_Jensen,

Welcome to the forum! What kind of iPhone do you have (model and iOS version)?

Is there any change in behavior if you try to uninstall Roon, reboot the phone and re-install Roon from the iOS app store?

Iphone 11 pro, Ios14.1 tried all the usual suspects, delete,reboot, reinstall app, to no avail.

Hi @John_Jensen,

Do you by any chance have any VPN or network filtering tools on the iPhone (for example is it a company phone)?

I’ve tired to enable diagnostics mode on your iPhone, and what this should do is deliver a log set from the iPhone to our servers.

Can you please try to open the Roon app a few times on the iOS device, use it for a few minutes, and let me know once you have done so? I can then check for the report, thanks!

NO VPN, I have tried several times now, the issue persists.
All tried to delete Remote , restart and reinstall to no avail.

3 posts were merged into an existing topic: Too many errors to continue playback - Tumbleweed Connection

Still no updates?, I have less than 7 days left of my trial!, do you have anything I can try?

Hi @John_Jensen,

Can you please let me know the exact local time + date you experience this behavior next?
I would like to enable diagnostics mode for you iPhone after receiving this information.
I’ve also followed up via private message regarding your trial!

Monday December 7th, 20:02 local time

1 Like

Hi @John_Jensen,

Thanks for letting me know that timestamp. I’ve activated diagnostics mode and what this should have done is deliver a log set from your iPhone to our servers, but I am not seeing this report come in.

I have re-enabled diagnostics mode for your iPhone just now, can you please try to use the Roon app again for a few minutes and let me know here once you have done so and I’ll re-check for the report?

I have just tried twice, local time 21:36, just to let you know that I cannot use the app at all.
Here is what happens:1 I open the app on the phone and as soon as it finds the roon server the iphone app goes in background.
If I Turn off wifi or close down the server app on my Mac it works like expected an is looking for server.
On my ipad it work perfectly every time, so basically I cannot use the iphone app for any amlount of time.
i could send you a video of what happens if it could help.

Hi @John_Jensen,

Unfortunately, it does not look like the diagnostics report is being delivered, the Roon app appears to be crashing before this report is delivered.

Yes, can you please upload a video and send me a link? Thanks!

1 Like

Hi @John_Jensen,

Thanks for sharing that video! Unfortunately, I am not seeing the log report be delivered on our end, but we do have an active investigation which looks very similar behavior to the video you sent, so I have added your report to this investigation.

From your video, it looks like this issue might be related to your network settings, so if you want you can try to perform a Network Settings Reset on the device and see if this helps.

Thanks in advance for your patience while our investigation is in progress!

A post was split to a new topic: Roon App Crashes

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.