iPhone - Audio Endpoint Missing

Sorry I know I am now posting twice as I have just commented on this issue in an iPad Pro thread. I am seeing the same behaviour a lot with my iPhone XR. I launch Roon on my iPhone and try to select my phone as the audio end point and its missing. I then go to settings > audio and it’s enabling. I tap on the gear icon and select disable then enable and the app crashes. Then a relaunch and repeat action gets it working. This is happening most of the time now and has been for the past few months or more. Annoying as I can no longer just get on and listen to music but have to fiddle around to get it all working. For me it happens everytime I come back to using my iPhone with Roon after a break of a few days.

Hi @Sam_King,

Can you please provide some more information regarding your setup?

  • What kind of Core are you using?

  • What iOS version do you have installed on your iPhone XR?

  • Does force quitting the Roon app and re-starting it resolve this behavior?

I am running the latest version of Roon core with the latest update on my iMac. This behaviour wasn’t fixed by the recent Roon Core update. I am running iOS 13.3.1 (latest) on my iPhone but same was happening before the latest iOS update. And lastly as I was saying the app crashes when I first try to enable my iPhone as an end point and on relaunch I can enable it ok but I do need to enable it as it won’t just appear in the zones as it used to in the past.

Hi @Sam_King,

Can you please let me know the exact local time + date you next experience this behavior? I would like to enable diagnostics on your iPhone after receiving this info to see if there are more clues in iPhone diagnostics regarding the crash.

Thanks @noris I will do this and report back.

1 Like

Hi @noris. It has just happened. The exact time was 9:40am. At first when I attached my Dragonfly to my iPhone my phone was visible as an end point. But I wanted to do something else so swiped away the Roon app, essentially closing it. Then went back to Roon and my phone was missing as an end point and once again showing as enabling in settings. When tapping on it trying to enable or disable the app crashed.

Hi @Sam_King,

Thanks for letting me know the timestamp. Diagnostics mode has been enabled for your iPhone and I can confirm that logs have been received, I have located the crash trace and I have submitted the log package to QA for further analysis. Once I hear back from QA, I’ll be sure to let you know. Thank you!

1 Like

HI @Sam_King,

I’ve spoken to QA regarding this behavior and they are aware of a couple of similar reports of this and are investigating, however we don’t have any time-frames to share when the investigation will be completed.

Thank you again for your report, but at the present time I would suggest re-launching the Roon app if this behavior occurs again while the investigation is underway.

Checking to see if there is any update on this. I’m experiencing the same problem. Roon sees my iphone in the Setup/Audio window and shows that it is enabling. It never enables and if I try to give the endpoint a name then Roon crashes when I press enter. Crashing happens regardless of using Roon remote to set up the iphone as an audio device on my laptop or Roon remote from my iphone to attempt setting it up.

I was wondering this myself as same still happening for me. I followed @noris advice and I don’t even bother going into settings. I just close and swipe away the app and that seems to sort it. But it would be good if it just worked all the time. It is strange how it is intermittent behaviour. Like tonight I haven’t used Roon on my phone for hours but just launched it and my iPhone showed up as end point no problem! But I know sometime very soon it won’t Iand I won’t have done anything different as far as I can tell.

Don’t know how relevant this is but I was having exactly this issue but since reserving an IP address on my router the problem has resolved. Been absolutely rock steady since doing that.

Could be coincidence but thought I’d at least mention it.

Any update or possible official resolution for this issue? The issue as described is exactly as I experience it basically every time I want to listen on my iPhone: it’s unavailable as an endpoint until I go to settings and try to enable it, at which point it crashes. Usually on restarting Roon it will show the phone available as an endpoint again.

I have the same problem with an iPad.

And this is a record of the behavior:

I tried to disconnect/connect the DAC, refresh the audio device without success.

1 Like

Hello @AlanTS/@Jimmy_Legrand,

Thank you for the additional reports. QA is aware of this issue and we have a development ticket regarding it. I can’t specify when exactly it will be addressed, but it is in the queue.


Thanks @noris. I appreciate the update and knowing this is being tracked.

1 Like

I am facing the same problem with an iPad mini. It is really frustrating. Is there any solution in sight?

Hi @Ariel_Katz & others following this thread,

Are you able to force quit the Roon app (double press home, swipe Roon away) and restart the app, does that help?

We are still looking into this issue but reproducing this behavior in the QA lab is proving to be a bit challenging. Are there any additional reproduction steps you could share?

What audio device are you connecting to your iPhone/iPad? Are you just using it for it’s internal speakers? Does this issue reproduce more with a certain type of audio device (Bluetooth / USB)?

Yes, I can force quit the Roon app and restart it. It eventually helps but often only after several rounds of force-quits and restarts.

The audio device is a Cambridge Azur 851D DAC connected to the iPad with USB. image

A few days ago, I grouped another zone and since then the iPad drops seem to have stopped, or at least occur much less often. I hope this information helps.

1 Like

Thanks for the info @Ariel_Katz, let me discuss with our hardware team to see if they are able to reproduce this behavior in the lab.

Just want to add in that this problem occurs for me 99% of the time on iPad and iPhone. It’s been happening for months, on various updates in the software etc. I figured out the force restart thing myself before seeing this thread, but even then that doesn’t always work — and is a pretty ridiculous process to go through every time you want to listen to something!