Iphone\ipad app doesn't connect to core

installed roon 2.0 core on my pc. installed roon app on iphone and ipad.
find roon os - on find.
when starting apps - looking for your roon core screen comes on - doesn’t find the core.
when turning the app first and then starting the core, app finds core, “connecting” flashes, but doesn’t connect. turned off firewall, still doesn’t connect.

Welcome to the forum. Did you maybe install the earlyaccess version on some devices, but the production version on others?
What are the version numbers you have?

Is your Core wired?

Plus, I moved your post to the #support category because it’s a request for help and not a discussion

core - roon version 2.0 (buitd 1148) - 3F4BBE61-3640-42FF-A9E1-BA014599EC1F

iphone app - version 2.0.01148

OK, thank you. The versions are fine. Wifi is not ideal for the core, but in this case we can at least rule out a communication problem between wifi and wired network.

Maybe silly question: Is your iPhone and iPad connected to your wifi network?

yes. connected to the same wifi network.
as i said when turning the app first and then starting the core, app finds core, “connecting” flashes, but doesn’t connect (image attached).

Ok. Try turning off the firewall on the PC temporarily to check if it helps

already did that - same result.
one more thing that might help is that i connected the core to my denon4500 receiver but when i play a song through the core and choose denon it looks like it’s playing in the core but nothing happens in the receiver.

I see now that you tried the firewall already. Oh well.
The Denon thing is also not right, but I would guess it’s a separate issue as it does not seem to involve the network. Let’s stick to the network first :slight_smile:

Can you find out the IP addresses of your iPhone and iPad on your wifi and try to ping them from the PC? It will most likely be successful, but just to rule that one out

i dont know much about pinging so i followed instruction and got this.
i think its ok.

Pinging with 32 bytes of data:
Reply from bytes=32 time=155ms TTL=64
Reply from bytes=32 time=60ms TTL=64
Reply from bytes=32 time=70ms TTL=64
Reply from bytes=32 time=65ms TTL=64

Ping statistics for
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 60ms, Maximum = 155ms, Average = 87ms

Yes. It’s ok. It would have complained in clear terms if it had been unable to find the IP.

Sooo, a little out of ideas now. Let me ponder. Maybe someone smarter will chime in

I don’t know how it works on the iphone, but on my iPad I have to disable “Private Network” under network settings, so the iPad can connect to the Core via Roon Remote App.
Just an idea

1 Like

And just in case it still doesn’t work, reboot everything, including your phone and iPad

@Axel_Lesch is onto something with a Windows PC running the Core. @liron_zahavi, have you made sure your home WiFi network is set to “Private network” and not “Public network” in your Windows Network Settings? The Private network setting allows devices to be discoverable on the network and to connect to them and is appropriate for a home network.

1 Like

i didn’t find “Private Network” but i did find “Private Address”, disabled it, but it didn’t help.

you were right. changing from public to private solved the connection problem!


woohoo! Enjoy!

1 Like

now a new problem happened. when the connection was made the app asked to upgrade the versions. once i clicked it, roon core stopped working and wont load…
i installed it again but still doesn’t load.

Can you create a new support thread as this is a dfferent issue related to updated software release?

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.