iPhone XS and iPad Pro loses connection

I am on a Roon Software trial. Test Core is a Windows 7 Intel i7 HTPC with built in gigabit network card connected to my network via ethernet. Audio is via onboard ASUS Xonar Essence STX sound card, digital output connected directly to McIntosh MX-160. WiFi Router is ASUS AC3100 for iPhone and iPad.

The i devices lose the connection to the core on a regular intermittent basis, more than 50% of my usage time so far. All of my other apps on the i devices work properly and a WiFi signal test on the i devices tests Good. All connectivity between the Core and the LAN and the WAN test fine.When this happens, the only way I am able to control Roon is on the Core itself. If I decide to integrate Roon into my system, I would contemplate the purchase of a headless Core, possibly a Nucleus+. However, with this issue, I would not be able to control the system. @SteveSilberman

Out of interest - have you tried restarting your wifi when this happens?

Whenever I have such problems - that is always the resolution for me.

Thank you. Yes I did, but that only resolved the issue for about 30 minutes average. I would be willing to use a new WiFi router if that would solve the problem, but because everything else is working well on WiFi, it would suggest that the Roon apps are more sensitive that my other applications.

Hi @Terry_Deeb,

When the devices disconnect, is it when you’re actively using them? Or is it when they wake from being idle?

How is your Core machine connected to the network? Is it connected directly to the router or is there any other networking hardware (switch, powerline adapter, etc) involved?

Do you have any active antivirus or firewall on the Core machine? If you temporarily disable them do you notice any improvement here?

No the devices do not seem to disconnect when I am actively using them. it is when they wake from being idle.

The Core machine is connected to a TP-Link TLSG1024DE Switch via an in-wall Cat 5 ethernet cable. I have used this cable for many years with no issue. I have just changed the connection to a Netgear 16 port Gigabit switch, which is connected via a different cable to the same TP-Link switch above. I will see if this makes any difference.

There are no firewalls between the Core and the switch/router. The Core machine is using Microsoft Security Essentials. I have not tried disabling it, but will try that after I determine whether changing the network connection, as described above, has any effect.

UPDATE: Changing the connection to a different cable and switch configuration did not solve the issue. It lost the connection on both of my devices on the next wakeup from idle. @SteveSilberman

Usually when the Roon app cannot find the core it helps to quit the app and start it again.
At least it does for me.

Thank you. I have tried that multiple times.

Hi @Terry_Deeb,

It looks like the TP-Link switch you were using is a managed switch, which often requires some additional setup (as mentioned in our KB). What is the model of the Netgear switch you are using?

If possible, it may be worthwhile to test using the Core connected directly to the main router via Ethernet, bypassing any switches, so we can determine if this behavior still occurs in this configuration. In the past we have seen this type of behavior stem from managed switches interfering with the remote’s connection to Roon.

When the remotes are unable to connect, if you were to use an app like Fing that scans the network, are the iOS devices able to see the Core machine?

My WAN/LAN system is as follows. I have Spectrum Cable internet. I have a Netgear ProSafe SRX-5308 Security Appliance connected to the WAN port of the cable modem. The ethernet output of the ProSafe is connected to the TP-Link Switch. One of the LAN ports on the ASUS AC3100 WiFi Router is connected to the TP-Link Switch. (Note: I also have an idle HP ProCurve 1410-24G Switch which is available to be used in troubleshooting process if it would be helpful?) I have tried both the 2.4 and 5g WiFi bands with the same result. The management functions of the TP-Link switch appear to be very limited. I have never adjusted them from the default.

To test your latest suggestion, I have plugged the Core machine directly into one of the LAN ports on the ASUS AC3100 WiFi Router, which would seem bypasses the switch as between the Core machine and WiFi router. The result of that test, was that the WiFi connection came up. I started a playlist and let the i device go to sleep. When I woke it up, the connection was again lost.

I am not sure how I would completely eliminate the switch and still have a connection between the Core, the WiFi devices and the internet, but with this additional info above please make a suggestion.

Thank you for the additional information here, @Terry_Deeb.

I think the next step here is to enable some diagnostics on your account so our technical staff can get some more insight into what’s going on here.

However, before I enable this feature, I’d like to ask for your help ensuring we gather the right information.

First, can you please reproduce the issue once more and note the time at which the error occurs. Then respond here with that time, and I’ll make sure we review the diagnostics related to that timestamp.

Hi @Terry_Deeb,

I had a chat with the team about what you’re experiencing here any have a couple questions for you:

  1. If you use a non-mobile remote (Mac or Windows) do you see similar behavior?
  2. On the router, do you have any additional firewall settings enabled, or anything that may interfere with devices communicating over the network?

Based on the team’s feedback, it definitely seems like there may be some networking troubles here. The team has suggested a test that would help us narrow down the possible list of causes to what you’re seeing. If you could temporarily connect the router directly to the modem (bypassing the other networking hardware) and connecting the Core directly to that, is there any change in behavior?


Hi Dylan,
Thank you very much for digging into this. I love the Roon concept and software and if we can get these issues solved, I will likely purchase a Nucleus+ to use as my Core. I have some questions about how that would best be configured on my system, but will save them until we get this issue behind us.

In answer to your prior post, the error occurred several times between 9:00pm EST and 9:30. Specifically at 9:24 and 9:28, my iPhone would not connect upon attempting to wake it. I assume that there should be no issue with connecting the iPhone and the iPad at the same time, although the issue seems to occur whether both are connected or only one is connected?

With regard to your last post, I assume you mean connecting the Core to the WiFi Router and connecting that directly to the cable modem. I will give that a try tomorrow, although it may require some reconfiguration, as my DHCP is handled by my Netgeat SRX. That may not matter, as the Core machine has a static IP.

I have downloaded Roon to my MacBook Pro to see if the issue repeats itself. I will put it through the paces and see what happens.

1 Like

Hi @Terry_Deeb,

Correct, you can connect multiple remotes at the same time without issue, so that will not be causing what you’re seeing.

Yes, it will definitely be a good idea to test with this configuration. As I mentioned above, this behavior is similar to what we’ve seen when networking hardware is interfering with the remotes connection to the Core machine. This may be stemming from the switch or Netgear SRX, and this test will help confirm that. Once we trace down where the behavior is stemming from then we know where to look into modifying settings to try to resolve.

Definitely let me know how this goes as well. If you notice any difference that would be a great data point.

Good morning Dylan,
Last night after 9:30pm, I was able to use the system for several hours without incident. Occasionally, upon wakeup, one of the i Devices would get the Waiting for connection message, but would reconnect within 10-15 seconds. I don’t recall ever using the connection while actively using the remote i device. The only thing different is that the Core machine and one of the remotes did a software update. I am not sure if that made a difference. Presently the Core machine is connected directly to the WiFi router with the router being connected to the switch. I am going to leave it that way for now, to see if the connection issue re-appears.

Also, I am not sure if this is helpful or related. I also have a Mirage Music Server Model MMS-2a. When it sits idle for days, I lose my main video display and have to reboot it. After rebooting, it takes a really long time for the i Device apps to connect. Like maybe 5 minutes or longer. However, normally when the apps wake up they connect within a few seconds without issue.The app for this model has a really bad rating, so I have always assumed that is one of the reasons why. Happy Thanksgiving to you and your team.

Typo correction above. I don’t recall ever losing the connection while actively using the i device.

The Roon Remote Mac App has crashed with the message :Roon has quit unexpectedly. I have a PDF of the “Problem Details and System Configuration” but have not been able to upload it here. Please let me know how to get the file to you.

Hi @Terry_Deeb — PM sent.