iPhone XS on iOS 14.3 Roon App Keeps Crashing on Launch

New user here. After setting-up my Nucleus, the iOS Remote app crashes immediately after connecting. Initially, I was able to use the app to connect to the Nucleus and update the software. But since the update completed, I can’t get the app to launch without it crashing.

I’ve tried uninstalling/reinstalling the app and rebooting my phone 5+ times without success. After each reinstall, the app crashes as soon as it tries to connect to the Nucleus. Subsequent attempts to launch the app result in immediate crashes. I’m using an iPhone XS on iOS 14.3. I also tried to install the app on a different iPhone and got the same result. Restarting the Nucleus and reinstalling its OS
does nothing.

I’ve been able to control the Nucleus using the MacOS app on a laptop with no issues so far, but the lack of iOS control is incredibly frustrating. Any suggestions appreciated.

Hi @etr385,

I’ve just tried to activate diagnostics mode for your iPhone and what this should do is deliver a log-set from your iPhone to our servers next time the Roon app is active on it.

Can you please open the Roon app on your iPhone, let it crash a few times and let me know here once you have done so? Thanks!

Hi Noris,
Thanks for reaching out. I just tried to connect and had the app crash a few times. I also did a reinstall and let it crash some more. As I described above, the app crashes immediately on trying to connect to Nucleus, so not sure if my account is even active long enough to generate a log.
Thanks!

Hi @etr385,

It appears that the app is crashing before it’s able to deliver the report.

Would you by any chance be able to follow these instructions to reproduce the issue and retrieve manual console logs?

Working on the logs. It turns out my iPhone created a crash log back on 12/19 when this first happened - if you PM your email, I’ll send the .ics file.

A further update:

The problem seems to arise when the app tries to connect to the nucleus as a controller only. When I deleted my database and reinstalled the Nucleus OS, I was able to do 99% of the initial system setup using the app with no problem. It was only when I pushed the “finish” button at the end of the process that everything stops working on the App. After this point, it crashes immediately on opening every time without exception. The desktop client continues works fine and all of the initial setup choices I made using the iOS app seem to have survived.

Interestingly, if I reinstall the Roon app on my phone and go to the “connect” screen (but don’t press the button) I’m able to activate my phone as en endpoint using the desktop client and cast audio to it. Once I press “connect”, however, the app instantly crashes and I can’t see the phone through the desktop client until I do another iOS reinstall and repeat the process.

Not sure if all of this helps, but thought I’d mention it.

1 Like