IPv6, Roon and Google Nest Protect

Is anyone successfully using both Roon and Google Nest Protect? My Nest Protect connects to the WiFi but stubbornly refuses to complete its setup regime. After a lot of reading, I think this is likely down to it requiring IPv6 - I’m still not clear whether that’s just on the LAN or also via the ISP.

I have a fairly old router (Bipac 7800DXL) and enabling IPv6 didn’t do much except cause chaos with various network devices. APs are all Unifi AC-Pro. I plan to replace the router with a Unifi Dream Router when released in Q1 2022. However, I’m interested to hear whether Roon + IPv6 is feasible and/or any success stories including a Nest Protect. I know the best practice guidelines advise disabling IPv6. Thanks!

I’m not familiar with any Google Nest products that are compatible with Roon, so I can’t comment there.

But, I have a number of Roon Outputs and Controls that all run dual-stack, IPv4 and IPv6, and I’ve had no issues with connectivity between them and Roon Core (a ROCK build). I’m using all Ubiquiti UniFi networking gear as well, including an old USG firewall.

If I run a command like this on my UniFi USG firewall, I can get the IPv6 address that was assigned to my ROCK Core:

ROCK_IP=  # for example
root@Gateway:~# ip -6 neigh | grep -Fwi $(arp -na | awk '/\('$ROCK_IP'\)/ {print $4}') | awk '!/^fe80/ {print $1}'
// returns the IPv6 address of Core

Unfortunately, if I put that IP address in square brackets ([]) in my browser’s address bar, I’m not able to open the ROCK UI. Must be that ROCK only listens on the IPv4 address. I have another Arch Linux system that’s running Roon Server, and I see that it’s only listening on IPv4 ports, so that makes sense.

Perhaps, someday, IPv6 will catch on…just like the metric system here in the US. Someday…

1 Like

Thanks David, I suspect the problem here might be a combination of old kit (the router, and an old BT hub effectively used as a modem) and ignorance on my part as to how IPv6 works and how to configure it correctly. It’s good to know at least that it can work, so I think I’ll try again with the new router in due course.

Am I right in understanding that the switches don’t need to be ‘clever’? I just use Netgear GS105/GS108 variants.