IQAudio Raspberry Pi not showing up in Roon

Well, I’ve tried all that, and it’s not appearing in Roon, although it is appearing on the network (via wired ethernet). What should I try next?

Try restarting the Roon server.

If I disconnect my pi and restart Roon after say a power cut, because the pi is not on the network when Roon restarts, it doesn’t find it next time the pi is turned on. If I then restart Roon on the server it magically appears.

So there appears to be an issue with Roon remembering what it has been connected to in the past. Whether this is by accident or design I don’t know.

What does it appear as in the Audio Settings page - a Remote Audio device, or a Networked device?

I think I’m now seeing a Remote Audio device that wasn’t there before I restarted RoonServer, but I still don’t seem to be getting sound out of it…

OK - I’ve worked out what the “Remote Device” is - it’s set up when I create a Remote Desktop session into my server (where RoonServer is running). Then the playback via the Remote Audio device can be heard on the PC where the Remote Desktop connection has been created.

So then it would appear as though the RPi2 + Pi-Dac is not appearing as a Roon endpoint on the network.

This is how mine looks

and when playing

OK. Thanks for those images. There’s no entry under Networked devices on my RoonServer.

The RPi2 is certainly being seen on the network, and it responds to an attempt to login via PuTTY (although since I don’t have a valid userid and password, access is denied).

One thing - I notice that you have a DAC/DigiAMP combo, whilst I just have the PiDAC+. I wonder if that is not sufficient to make it a Roon Ready device?

I have the PiDAC and had the same issue as you - showing on the network, but not in Roon.

I rebooted the Pi2 twice (because it didn’t work the first time) by pulling the power and it showed up on the next boot.

I did nothing else before rebooting.

I also have the PiDac+ and it shows up fine in Roon

Having the digamp made no difference to me either, as I did have it playing into headphones directly from the dac originally.

If you have restarted the Roon server with the pi turned on and visible on the network, then I am at a loss as to what to suggest.

@Gordon_Garrity did email me after my post saying I’d got it all working, to ask if I had any network issues as he had several testers with the problem you appear to be having. So perhaps he will now see the latest posts in the thread and assist.

OK, thanks for the responses. I realise that the software is still not fully baked, so these sorts of things are only to be expected. I’ll wait for further developments.

One other thought; I’m running RoonServer, rather than Roon, on the machine where my media collection is held. Is it possible that this is why I’m not seeing the RPi2+DAC endpoint?

I’ve tried rebooting all machines and Roonserver any number of times, with no change: the RPi2 is present and running in the network, but no network device shows up in Roon…

I’m having the same issue as Geoff

It worked for a while - it was found by Roon after a couple of reboots of the Pi, but now, after a shutdown it’s disappeared again. From Roon that is - it’s on the network.

I’ve gone back to picoreplayer and squeezelay for now - it works perfectly, and frankly, I’m not sure I can tell the difference in sound, if there is any. I’ll try the certified final release when it comes out.

Still issue free here.

My set up is latest version of Roon server running headless on 2012 Mac mini, which is set up with fixed IP address. Pi getting ip address via dhcp from my modem/router. They are connected via switch in the living room and not via the wired modem/router or an wireless access points.

Have you tried simplifying your network as much as possible? I know you can’t connect your pi directly to your Roon server with an Ethernet cable as we don’t have a login for the pi to be able to give it a fixed IP address. Can you set up dhcp on the Roon server and just have the 2 devices and wire as the network?

Not that this helps much and is probably just annoying for those who can’t get it to work.

I’ve just followed Mehul’s lead and installed picoreplayer on the RPi2, and enabled Squeezebox support on the RoonServer.

Instant success.

I’ll carry on with this until Roon gets their RoonReady software sorted.

Hi Geoff, I’m sorry to hear you are having issues. Could you let me know please what version of Roon server you are running, which OS variant, a little about the network topology etc. You can email me directly at gordon @ iqaudio . com

I’ve explicitly locked down the software to IQaudio boards so details about your Pi’s version would be good too.

Thanks in advance,


I have been running PiCorePlayer on my Pi/DAC and Roon has been recognizing it as a SqueezeLite player. It works beautifully. When I first tried RoonReady, Roon could not find my PI no matter how many times I rebooted things. I then changed my network configuration so my Xfinity cable modem acts as the router and my Airport Extreme acts as a bridge as opposed to vica versa. Now Roon sees the Pi perfectly! My cable modem connects to the Airport Extreme via ethernet, and my Mac runnng Roon any my Pi connect via ethernet to the Airport Extreme. Not sure why changing the router and the bridge made a difference, but it did!

To anyone having discovery issues, please try the following and report your results:

  1. Get into the bad state, where the Pi is running + Roon can’t see it.
  2. Power cycle the Pi, without removing the network cable
  3. Give it a few minutes, see if the Pi shows up in Roon’s Settings->Audio
  4. If not, exit the copy of Roon that’s managing your library and restart it
  5. See if the Pi shows up in Settings->Audio

If the device shows up in step #3, then it’s likely that there is something to fix on the device side. If it shows up in step #5, it’s likely that there’s something to fix in Roon. If it doesn’t show up at all even after doing all of this, that points towards a networking problem.

I’ve sent an email to Gordon directly, but I’ve followed all of your 5 steps several times and still no joy.

It may well be a networking problem, but it’s curious that I can “see” the RPi2 over the network without problem, and that switching over to a Squeezebox setting immediately got the RoonServer talking to the RPi2 (having swapped out the Roon RC2 software for Raspian + Picoreplayer).

The network is all on a single subnet (192.168.178.xx), with wired ethernet connecting the media server (RoonServer 1.1 build 102, running Windows 10 Pro, version 1511, build 10596.122), the RPi2 + Pi-DAC+ combo, our HTPC, and my desktop PC. These are all directly connected via a network switch, which in turn is connected to our ADSL modem/router (a Fritz!box 7360). This acts as the DHCP server, but all the wired connections get fixed IPv4 addresses from the router. Oh, and IPv6 is also in use. The WLAN side of the router serves a number of other PCs, and there are also two Wireless repeaters in use to extend the network throughout the house and garden.

If it’s not working even after restarting everything, this is sounding less and less like a discovery problem.

It kind of sounds like the RAAT software on the Rpi is either not being started, or is failing to start up.

@Gordon_Garrity, I think the next step is to get a shell on the device and confirm that RAAT is actually up and running, and that it’s not having a startup failure or similar.

I hope this isn’t inappropriate to comment, but I thought from reading one of the other threads that RoonReady was all about not releasing things into the wild until they were certified?