Is an All WiFi6 System Even Possible? - Now Asus RT-AX86S Won't Do it Either

Roon Core Machine

HP Spectre 360

Networking Gear & Setup Details


Connected Audio Devices

Squeezebox x2
Google Home Mini x2
Sonos One

Number of Tracks in Library

All Tidal

Description of Issue

I simply can not get my gear to communicate. I have now tried two of these high-end routers…a TP Link and this Asus RT-AX86S. I can connect my devices to the network…I can stream on my core laptop, I can SEE my Sonos and Google Home Mini devices (I can’t see the Squeezeboxes) yet I can not stream on any of them. Roon simply loses control of the devices or indicates that it is streaming (moving bars next to a track) but doesn’t actually stream anything.

Perhaps there is a setting on this router that I’m missing?

I did attempt to contact Asus support and they just kept having me roll back stuff in the settings until the router was a legacy product with 1/10 the speed to my ISP it had out of the box and still nothing.

I can’t wire my system, it isn’t an option in this house.

What am I supposed to do? My old Netgear router only provides 1/3 the speed of any of these new devices I’ve tried, but does the deed for roon. The new routers are blazing fast, but won’t run roon - which is our favorite app…

There has to be a middle ground for a WiFi6 system.

What is going to work? Settings for the Asus? Different WiFi6 router. I’ve got $1000 in paperweights in my house right now…

The RT-AX86 is a fine router, in fact one of the best (I have one). How’s the signal strength to the Roon Core? You might want to try a factory reset and start clean. Also, do you have multicast configured? See my settings below:

1 Like

Thank you for your response @Richard_Wright - I started again from factory default and updated this setting - it is not working. Signal strength to my roon core (wireless laptop) is superb as they’re literally setting less than four feet apart.

I may try again - but I did the following series of events:

  1. Started from “new” with the router - completely factory reset
  2. Setup the network
  3. Changed the settings you indicate on LAN - IPTV
  4. Reinstalled roon software
  5. Discovered Sonos device (still can’t see Squeezebox devices)
  6. Tried to stream…

Nothing happened.

New tech is so frustrating…I just don’t understand why things can’t talk to eachother.

Do you use the same router all wireless?

@Richard_Wright - I did as you said and then turned off all of the firewalls on everything…that has worked…now that I’m connected I’ve turned back on the firewalls and been prompted for exceptions…


Thank you :smiley:

I’m glad it worked out. I’m not sure about the firewalls as that is probably very specific to your network devices. Are you talking about on your router? Or your PC? I still have my firewalls enabled on my router, but that should only impact network traffic outside of your LAN.

It required me dropping all of my Windows firewalls in order to begin operating properly…once the firewalls were down, it connected right away. Then I turned the firewalls back on and as I continued using the platform it asked me to generate exceptions.

Works now!

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.