Is it possible Roon 1.8 conflicts with ISP's security protocols?

I get my internet access from Comcast. Since Roon “upgraded” to 1.8 I get no album or artist artwork. None. It isn’t just slow. I get nothing. It isn’t killing me because the service still works and frankly I don’t spend hours looking at that ■■■■ anyway, but aesthetically it is kind of a drag. As it is becoming clear what is involved in the change I am wondering if it might not be some incompatibility between this approach and my ISP. Anyone else getting that impression? Any other Comcast prisoners out there?

Have you tried changing your dns provider to google and

Do you have ANY firewalls or access restrictions? I checked your logs and some things are getting through to our servers just fine, yet other things are being blocked. Your system was able to reach our servers to send us logs, so things ARE working, but many of your TIDAL and image connections are failing.

Your DNS seems fine, but the connections themselves are being blocked. Maybe a web proxy? Maybe firewall rules?

Comcast is a pretty big ISP and probably isn’t targeting half of the Roon infrastructure. I bet it’s something local on your router or machine.


Thanks Danny. It’s something to look into. Not sure how to do that. Getting tech help out of Comcast is no day at the beach but it makes sense that the router is where the problem is. Two of my remotes work with Wi-Fi and one is hardwired with Ethernet. They all look the same.


So to be more precise I am in the Apple universe. I have endpoints that are controlled by an iMac an iPad and a MacBook Pro. Then there is an iPhone. Firewalls are off on the machines. The issues are consistent across all the hardware. The commonality is the Comcast X1 router. They brag about its security but I suspect it doesn’t get along with your latest software update. Doesn’t seem to affect functionality and I suspect that eventually you guys will work it out. Maybe there is something I could do at this end to disable their security nonsense but it doesn’t seem like that should be necessary.

I use Comcast as my ISP, and it’s an Apple home, except for the MS Surface tablet running my Roon core. My iPads are working just fine as Roon remotes. However, I use an old Apple AirPort Extreme as my router, and my own NetGear cable modem. I also use Google DNS (, FWIW.

Good luck!


That makes me even more suspicious of their new router. The goofy looking slant top box thing they advertise on TV. With their app there are settings you can use to supposedly bypass some of the security for gaming on a device by device basis. They warn you not to do this on a sustained basis. I tried to for the iPad but it had no effect on Roon’s performance last night when I tried it but maybe overnight? Who knows? Maybe it is just time for me to buy my own router.

The router is the Xfi Gateway TG 4482A. I have turned off the firewall and there is no improvement. So… kinda stuck.

I get about one page of album covers (out of 2100) on the machine that is hardwired with ethernet. Nothing on the others. Pretty much given up on the visual experience. But I don’t listen to music for the visual experience so, I’m not exactly heartbroken. Maybe someday…

Hey @James_Ward,

Can you install our latest update, Build 903 on your Core and remotes. It has some fixes that should help.

2/18/22 Fixed!!!

Great work guys. I knew you’d get it sooner or later.



This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.