Is my issue with Roon, or my Rpi or dietpi?

I am using an Rpi running DietPi (thanks again for everyones help) and feeding a Chord Mojo.
In an effort to improve the Mojo, I have tried two things…neither which seems to work.

  1. an Olimex usb isolator…think of it as a cheap Intona
  2. using an Elijah Audio split usb cable to run 5v of battery dc to the Mojo.

In both cases Roon fails to see the endpoint (just like when the Mojo runs out of battery.

Anyone have any ideas?

Have you try the Mojo straight to the Pi with a regular USB cable?

Yep works great.

The Elijah cable won’t work as ( and this is with my limited understanding of experiencing the same issue with a Hugo) power is needed for the handshake between Mojo and Pi but the Elijah doesn’t carry any power.

So it’s all to do with the cable and nothing to do with Roon, Rpi or dietpi!

I’d imagine your other issue is similar.


The cable sends 5 volts to the Mojo. The only difference is that the 5 volts comes from a battery instead of the Pi.
I’m sure there are others using the Elijah with a Hugo.

The dangers of alcohol and forums!

I missed the split bit…


1 Like

Not sure why thats a danger (says the guy who makes alcohol for a living!)

1 Like

@Stephen_Brooks So we now that the problems is before the Mojo and the Mojo is working fine with your Pi/DietPi :smiley:
Those are good news…

On the other hand a quick search didnt turn much on the Mojo and the Elijah Cable.
USB Cables that are custom do not follow USB standards and issues like this can come up. I bet you have a bad cable.

But it works directly from my macbook with the same Mojo and the same battery supply

Not the same. The Pi is not supplying the same USB power power as your Mac. You are entering a whole different world when competing the two. I had issues with my iUSB and my Gemini cable and I had to turn off isolator or “isoearth” on the iUSB for it to work properly after some playing I got it to work all together properly. But again this are wild guesses and maybe is not the same problem… To me it seems that the Pi is been sensitive to your specific setup and it does not like your cable or your Olimex.

I already bought a cable for $200 bucks and I just bought a battery supply. No reason the other ones wold work if these don’t

I’m thinking out loud here…not arguing. In my scenario, the Pi is not supplying any power. The 5v is coming form a battery power supply (the 5v from Musical Paradise)

I will try different battery supplies…I guess there could be a problem with the battery!

If the Battery is not working properly, You can run in to the issue where the isolator is asking for too much power and the Pi cant supply it. The way to test this, Is by putting the isolator on a Powered USB Hub and see if that makes a difference.

I’m having a problem and am trying to eliminate the cause.
I am using an Rpi (running dietPi) as an endpoint.

I want to split my usb cable and have the 5v that my Mojo dac
needs supplied by a battery, rather than the Rpi.

When I do this, the endpoint is not recognized in Roon. It does work splendidly
with both a macbook (running the Tidal app) and with iOS (also running Tidal)

What I can’t figure out is if its a Roon issue or an Rpi issue.

I’ve asked around in many different forums but it appears no one else is trying this combo.

Thanks for your help and thanks for giving us Roon!

I still stand that the issue is with your setup and not the Pi.
I am doing something similar with the difference that I am using the iFi iUSB with the Gemini cable and I do have the iFi PSU with it and it goes to my Pi2.

I was looking for an answer from Roon to see if it was a software issue. Thats why I posted in software.
I’ve tried a different battery and it made no difference.
I’ve tried powering up in a different order, still no go.

And I didn’t realize you were doing almost the same thing ( I didn’t recognize the iFi
names) Knowing that you made it work is very helpful…thanks

1 Like

Problem solved. I added a powered USB hub to the equation and now al of it works. I am not sure I understand why, but if someone has this issue in the future, grab a powered hub.
Btw, powering the dac with 5v from a good battery (not a phone recharger with cheap voltage regulators) makes a wonderful difference.

It’s simple, Like I said in the past, the Pi does not have enough power to drive your USB device hence why your power hub made it worked… I am glad you got it going! :grinning:

By the way I don’t think this is the way you want this setup… I think having a USB hub in the middle is defeating the purpose?

Its not perfect…who wants another crappy power supply in line. But I have tried everything else and can’t find another way to make it work.