Is my NUC bricked?

My NUC suddenly won’t switch on (not boot, I mean there’s no light at all showing when pressing the power button).

I don’t have a spare external power brick, but I don’t think it’s this, as having opened the top of the case I can see the green light on the motherboard is on.

Anything I can try before assuming something has completely bricked a year-old NUC?


Green led on external power brick is indicate that brick ois connected to power outlet. This is not meaning that it is working and it is providing power to your NUC. So, better check if external power brick is providing power to the exit connector.

1 Like

The green light is on on the motherboard in the NUC, not in the external power brick.

Have you tried reseating the RAM sticks and any M2 SSD to start with? Is it in it’s original case? Have you tried connecting it to a screen to see what happens when you turn it on? Lots of questions sorry.

1 Like

Hi, Ihaven’t tried those yet but can later on. Would any of those cause no light at all on the front of the case on startup?

It’s in an Akasa fanless case, but has been for over a year and running cool/working flawlessly.

It’s weird, it booted up perfectly then I had to turn off to reset the network as my router didn’t find it. When I came back to turn it back on again 2 mins later it was dead as a dodo.

Not going to lie you it doesn’t sound great. I’ve run self builds of all kinds for years. This is my one at a time checklist…

1 Like

Yeah my instinct is it’s not great, but I’ll run through the checklist in any case.

If none of those work, would you look at a new external power brick first, or can you get new boards for these NUCs?

The very first thing I’d do is connect a screen and see what it says. If the screen has any info on it then a recovery from USB might be worth considering.


Sounds like it could be a BIOS problem.

Once you hook up a screen, it will probably be apparent what’s wrong.

1 Like

Thanks guys. Screen first it is, then.

Just out of curiosity, does the motherboard have a battery on the board supplying power to any NVRAM, like the BIOS? That could be the problem on a reboot.

1 Like

For the moment this is fixed.

Not exactly sure what the problem was, as my monitor is still packed (we just moved house) but my electronics kit was to hand, so I just opened it up took everything apart, disconnected the CMOS battery for 5 mins, then put it all back together again.

Wasn’t sure what would happen but it booted and is working just like nothing ever happened. Whether it was the CMOS battery reset, or just re-seating memory/HDD or just the power connector, who knows and as long as it’s working I’m going to leave it alone!

Now I just have to work out how to re-enable USB which is disabled in BIOS as I temporarily have to use a USB input on my Oppo instead of my usual streaming DAC which is in for service. I’m thinking hold down the power button for 3 seconds then that should get me into the boot menu…?

Thanks to everyone for your help and suggestions :+1:t2:

1 Like

Assuming it’s an Intel NUC see if this helps:

1 Like

Thanks, will give it a try in a minute!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.