Is there a way to re-install the most recent version of the Roon Core on a Nucleus? [Solved - Roon Version on Remote needed updating]

I recently purchased a Nucleus. I successfully connected it into my dedicated hardwired network with my dCS upsampler and DAC, and I control it with an iPad running the Roon remote app. I was able to log into my Roon and TIDAL accounts. (I was previously running Roon on a MacBook Pro). At the outset of running Roon on the Nucleus, I got a message on the remote that an update was available for the version of the Roon Core running on the Nucleus. I allowed the Nucleus to update. Before the update, I noticed that Roon was not recognizing MQA files from TIDAL; after the update it recognized MQA files (meaning that MQA shows up on the thumbnails of the relevant albums). Roon is also performing the first unfold of those files, so that 24/96 is going to my dCS upsampler (based both on the input display on the upsampler and the signal path information in Roon). But there are two problems: (1) The signal path information shows two unknown filters in the signal path rather than the Roon unfold (which was properly displayed when running Roon on my MacBook Pro) and (2) the tab allowing me to specify whether my downstream devices encode and/or render MQA is missing, so I cannot let the dCS device handle the MQA processing.

I suspect the problem was a faulty installation of the update. If so, how can i force a re-installation of the update? Could there be another problem?

adding @support so they get notified.

I would wait for a response from support before trying to reinstall…

You might check the WebUI of the Nucleus for a re-install feature.
There is a web ui you can get to from sidebar -> settings -> setup -> configure roon os devices

Thank you. The WebUI provides for a reinstall of the operating system and a restart of the server, but not a reinstall of the Core.

I believe the Operating system would include the Core in this case. Maybe support can chime in here to help??

edit: When you look at the “device setup” screen, do you see “show advanced” ?
When I click this and scroll down, I see an “Enable MQA Core Decoder” is that what you are looking for?

Edit 2:AH. now I see it, in my oppo screen at the top it shows MQA capabilities, That is probably what you are looking for…

Frustrating that I cant show screen shots for some reason…

Thank you for the clarification. I tried the reinstall of the Operating System in the Web Administration Interface last night. It reinstalled but didn’t fix the issue. I may have misdiagnosed the cause of my issue.

You’ve correctly identified what I am looking for (Enable MQA Core Decoder). It was in Roon running on my MacBook Pro, but I didn’t see it in Roon running on my Nucleus. Now that you’ve reminded me of the location, I will check again tonight when I get home.

Did you try to reboot the dCS?

Sometimes a reboot of the entire system from core to endpoints is needed for ever one to be “happy” and talking to each other. :slight_smile:

I rebooted the upsampler, but I will try rebooting both the upsampler and the DAC.

Hello @Harold_Novikoff,

Thanks for contacting support, I’d be happy to take a look over the issue you are facing here and thanks @bearFNF for the initial reply while we had a chance to look this thread over. Our MQA features have only been enabled in our version 1.5 (build 323) update, for you to properly see those features you have to make sure that you updated both your Core and associated Roon Remotes. The two ‘Unknown Filters’ you see would also indicate that something didn’t get updated properly along the way. Can you please confirm that you are using the newest Roon App on both your Nucleus and the Roon Remotes? Please let me know when possible and we can continue troubleshooting from there.



Thank you for jumping in. One of your questions led to the cure. The Nucleus is running the current Roon software and OS, but my iPad was not. I had not updated the OS on my iPad, so I had not been prompted to update the version of Roon Remote that had been installed on the iPad (the current version of Roon Remote is only compatible with the current iPad OS). I updated the iPad’s OS and then updated Roon Remote, and now everything plays and displays properly.

Thank you again for the help.

Hello @Harold_Novikoff,

Glad to have been of help, if there’s anything else just let us know! Thanks again for contacting support and hope you have a great day!


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.