Is this backward? (Roon + HQPlayer 3)


Been few weeks now and i’m coming back (to same Roon + HQPlayer setup).




I’ve always had the option in HQPlayer to allow control from network even though the localhost is used since same PC is used for Roon Core and HQPlayer. And i use HQPlayer CLI from different PC and Android app HQPDControl from tablet. No issues.


Today, Roon Core cannot playback IF the “Allow control from network” if enabled. What happens after hitting Play from Roon UI (running from different PC) is playback “stops” right away.

If that option disabled then Roon Core playback works with HQPlayer.

What’s going on?

My understand has (always been) regardless of localhost or not for HQPlayer with regards to Roon Core, best practice is to have this “Allow control from network” option (always) enabled.

Did i miss an announcement or memo about how these two work together with regards to this HQPlayer option?

To isolate, i can play the same album/tracks directly from HQPlayer in the same machine that Roon Core is running.


Thanks much.

Okay, i’m an idiot.

Working as expected.

Root cause seem to be from having HQPDControl interfering.

I realize that you can’t have >1 tied to HQPlayer during Roon connection with HQPlayer.

Forgot that i need to stop Roon playback --> change HQPlayer settings from HQPDControl/disconnect --> start playback

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.