Is upsampling done via Roon controls or HQ Player?

I’m a little confused about this. After some work, finally got HQP and Roon integrated. When first started listening, I noticed Roon app on iPad was showing everything as upsampled to 700+. I had set the Roon to upsample 2X and the HQ Player limit to 384 (highest PCM my Moon DAC will play. I presumed Roon was upsampling everything 2X and then HQ was upsampling again by 384. DSD files were also playing as PCM 384.

I cant find anything in HQ Player similar to Roon’s upsampling choices so not sure:

  • if Roon or HQP is controlling upsampling?
  • if it’s HQP, does Roon’s upsampling need to be disabled?
  • and, where do I customize the settings in HQPlayer. (I see that you can do that track-by-track, but I’m looking for something that’s more all-encompassing)
  • Do I have the limit of 384 set incorrectly? I thought that indicated max played on the DAC, not what would be played or upsampled to for all tracks
  • Finally, how do I enable HQP to play DSD without converting to PCM?

Thanks in advance for the help.

PS. I have large discrepancies in volume from file to file with HQ Player/Roon. Roon had volume leveling, but I don’t see that anywhere in HQP? Maybe there is a setting I’ve ignored or misapplied?

Both are on their own on this.

If you use HQPlayer, you’d generally want to disable Roon’s DSP features. So use either one, but you may not want to combine the two because you may get strange results…

HQPlayer settings, you can check the included manual for details.

Same thing usually, you’d want to upsample to highest rate supported by the DAC.

If you have DSD capable DAC, in most cases it would be recommended to output DSD always, regardless of source. Otherwise you can set output mode to “Auto” to switch between PCM/DSD depending on source (not really recommended).

Volume leveling is something similar to compression, IOW something unwanted.

Roon DSP has no effect on HQPlayer zones, so no action needed there. One down!

HQPlayer has a high quality digital volume control which can be used for attenuation but it does not read tags for any kind of volume leveling. Roon’s volume leveling can’t be used simultaneously. I don’t think I’m telling tales out of school in saying that HQPlayer developer Jussi Laako is a big album listener and HQPlayer’s feature set tends to reflect this.

I’m not sure what you mean by “track by track” upsampling settings. Since you’re new to HQPlayer, even helpful answers might contain jargon you’re not familiar with, so one way to proceed here would be a screenshot of your current settings. File > Settings.

What is your goal? This is an important point before people can offer meaningful answers. Do you want to upsample PCM to max rate PCM, DSD to max rate DSD? Upsample PCM to DSD, leave DSD as native? Something in between? Name of your DAC would probably help as well, maybe someone is already using it with the same model.


1 Like

@Bruce_Orr HQPlayer quick start guide which is a bit dated but covers the fundamentals, might be of use.

It’s a little more conversational in tone than the official HQPlayer documentation & maybe easier to follow. The HQPlayer manual does contain many interesting details itself though. Good luck :slight_smile:

Lorin - First a bit shout out for getting back to me for some quality coaching. Much appreciated. I’ll try to address your questions and add more context.

Roon/HQP running via ethernet to ultraRendy/IsoREGEN and then Lush USB to the DAC: Simaudio Moon 280D (to 384PCM and 256DSD). Library is Flac in all dimensions, DSD64 and 128

HQP/Roon Goals

  1. Upsample and filter both PCM and DSD by file type (16/44, 24/96, DSD64, etc), using customized settings, as I can with Roon. Short of that, learning how to enjoy 2x and max would be nice.
  • I have since learned 2-wire in Preferences means 2x upsampling.
  • I’m puzzled since I don’t believe any of my attached settings indicate any upsampling at all, yet here is the upsampling occurring:
    44/14 > 352
    96/24 > 384
    176/24 > 352
    192/24 > 384
    352/24 > 352
    DSD64 > DSD128
    DSD128 > DSD128 (DAC will not go to 256 with my MacOS)
    DSD256 > DSD128 (same)

I’m sure you’ll have a simple explanation for this, I just can’t get there!

When I have selected 2-wire (believing it to indicate 2x upsampling), at lower PCM levels the music is slowed down to a drawn-out crawl, and much worse for DSD.

  1. Avoid converting DSD to PCM unnecessarily (understand how to do either)

  2. Enjoy volume leveling without serious exercising of controls. BTW, volume via HQP seems significantly louder overall vs. Roon. I’d prefer avoiding pushing levels closer to max on either the HQP or system volume controls.

  • From what you said, volume leveling is a non-starter for HQP, but perhaps there is something that can be done with volume gain being lowered.

Settings Screen Shot

Again, your time and coaching is very much appreciated.


You mentioned Roon has no effect on HQPlayer Zones. I believe you, but it appears otherwise at least in some indications: Headroom Management set on Roon is displayed in the System Flow diagram for all tracks - before the point where it says Leaving Roon. If I change the headroom from 3 to 6, System Flow reflects the change.

Greetings @Bruce_Orr I couldn’t figure out where this discussion was moved to at first, but here it is. Hopefully my answers are not too long winded—as some dead writer is supposed to have said, “I didn’t have time to write a short letter so I wrote a long one instead.”

First, 2wire is something to do with i2s. That’s all I know, other than you most likely want to leave it unchecked.

The “sample rate” and “bit rate” settings can be considered the target, the rate you wish to upsample to. I’m not aware of a 2X upsampling (44->88 96->192 etc) setting, but outputting at max available rates is typical and a general recommendation. So with auto-rate family set and a max of 384, the output you are getting is expected. Any 44.1 family tracks will be upsampled to 352, 48k to 384. NS5 is one type of dithering recommended for such high rates.

On to the SDM (DSD) side of things. The 32k x256 setting is definitely not what you want. According to its manual the 280D supports 11.2896mhz DSD, so set the Bit rate (/ limit) field in the main settings to 44k x256 (48k x256 being 12.28mhz, not supported. HQPlayer should have no trouble playing 24/96 or 192 material with these settings though.)

Edited to add: Just realized the mac is limited to 128? In which case, 44k x128 would be the setting you’re looking for.

Edited further to add: If you’re using an NAA, I don’t think the mac dsd 128 limitations apply. It comes down to the capabilities of the UltraRendu, which can output dsd256. Sorry for the confusion!

Interesting on the headroom management, noted. I hope anything I get wrong here, someone can correct, as I don’t use it myself. HQPlayer’s volume limiting is via Vol Max as seen in the main settings dialog. -3 db is the standard recommendation, I personally use -10 db which lets me run my integrated amp around high-noon which I consider to be its sweet spot. There is still a drastic amount of volume difference though, loudness wars and all!

If you do want to try leaving dsd at its native rate, tick Direct SDM in the DSD/DSDIFF settings.

I’ll check back later and see how you’re getting on, cheers :slight_smile:

I guess I didn’t address how to upsample PCM->PCM and DSD->DSD, because I upsample everything to DSD. In the main transport view, on the far right hand side, there is a drop-down menu which should show PCM, SDM , Auto. Select auto.

I imagine this setting will persist, but there is probably a way to set it in the configuration file as well.

Lorin, thanks for your detailed reply. I’ll check things out tomorrow and get back with you


1 Like

The various Mac limitations on DSD rates indeed apply only to DoP when the DAC is connected directly to the Mac (and depend on the design of the particular DAC in use). In @Bruce_Orr’s case, since he’s using an ultraRendu (so native DSD should be possible), you’re correct that these limitations don’t apply.

I couldn’t find a reference to indicate that the 280D wasn’t capable of “48 x256” rates, so I would switch the HQP “SDM Pack” setting to “none” and leave the HQP SDM bit rate setting at 48k x256. If it turns out that the 280D really can’t achieve the 12.28MHz rate, then it’d be appropriate to change the HQP bit rate to 44.1k x256, but in the meanwhile, no real harm done.

Also, I’d recommend at least trying one the SDM modulators that are optimized for DSD256, i.e., DSD5v2 256+fs and DSD7 256+fs.

(This is really all just nitpicking, though helpful, I hope — you’re doing a heck of a job coaching @Bruce_Orr.)


Thanks for ALL the HELP! I’m learning and appreciate your support. I am not currently at home and therefore test some of the questions below on my system, so appreciate your addressing them on paper ahead of that.

  1. If you’ve not looked at the 280D manual, the following quote and spec info from that document are provided in hopes of eliminating any ambiguity and helping me learn more about what the 280D’s capabilities are.
  • “Fully asynchronous DAC supports native DSD64, DSD128 and DSD256 (USB only) and PCM up to 32-bit/384kHz including DXD (USB only).”
  • Simaudio 280D Sampling & Bit rates

You’re right I see nothing saying 44/DSD is not supported, but seems like it would be included if it was? I’ll try whatever your recommendations on Settings are based on the above either way.

  1. So if I were to set SMD Pack to None vs. DoP, the specific SDM settings below that box would still be active? And DoP would be inactive? Files would play as PCM? Sorry, nost so smart about these things (yet!).

  2. I hope you are right that when using Mac in combo with uR, DSD256 is not limited on the DAC. I have not found that to be the case to date. Using the settings provided to Lorin yesterday, you can see that DSD256 down-sampled to 128, and neither DSD64 or 128 upsampled to 256. Perhaps, you see something in the settings I had been using that would have prevented this?

  3. Lorin and I began a discussion regarding the impact of Roon DSP Engine controls on HQP output about which we’d appreciate your clarifying comments. Lorin noted that the DSP Engine should have no bearing on HQP output and there is no need to disable any settings. I believe him, but noted when viewing the Process Flow, the enabled Roon Headroom Management setting was present and applied to every track before leaving Roon for HQP. Can you clarify whether any Roon settings affect HQP output?

  4. If the DSDFF/DSF Direct SDM box is checked it will play DSD files natively? No upsampling? How does checking that box affect the settings in Preferences regarding to SDM DoP/None?

Thanks to you both once again for taking the time to teach/enlighten. I’m sure I’ve already worn you out.



With regards to 5) It’s easy to confuse “native” DSD and native sample rates. Direct SDM means DSD will be played back at it’s native sample rate. DoP controls whether DSD is sent natively or in a PCM wrapper. Apologies to any pedants out there who would put it more accurately/clearly but that’s the gist of it.

1 Like

The “DSD Data Rate” entry in the specs, one line above your screenshot, tells me that the 280D is based on 44.1x DSD rates, which is quite common. In practice this means it might take slightly longer to initialize a filter for 24/96 etc material. I personally can’t hear a difference between integer and non-integer upsampling, I wouldn’t worry about this detail once you’re up and running. Anyway, if you’re testing to verify this, keep the volume relatively low until you’re sure playback is going smoothly.


1 Like

The forum software tells me to consider posting all my thoughts in a single comment but frankly I think this is easier to follow :smile:

When it comes to 2) pack SDM only refers to whether DSD is sent as DoP. This is not to be confused with converting DSD to PCM. It’s merely a container that allows certain devices to recognize a DSD stream as audio and (in the words of one of the originators of the standard, dCS) “reassemble the original stereo DSD data stream COMPLETELY UNCHANGED.” (Emphasis theirs)

But if you can playback native (ie pack sdm 0), all the better. I mean, some people can hear a difference. I believe it uses slightly less bandwidth which is why I use it for streaming over wireless.

Regarding 4) once you’re up and running let’s see a screenshot of the process flow to verify this. It may be a case of the iPad app not offering me 100% functionality when it comes to dsp, I think that’s a thing. I don’t have roon installed on a desktop because I only run Linux. When I have the HQPlayer zone active, none of the roon stuff is available for configuration.

I’m off for the afternoon, good luck!

Lorin – below please see screen capture from iPad showing Signal Path. As I read this, it appears Roon is applying DSP Engine Headroom adjustment to files being sent to HQP. Whether HQP is ignoring that information I do not know. Your thoughts?

From your signal path, you’re still upsampling in PCM. In the main HQP window, set the rightmost pop-up to “SDM (DSD)”, and then all source material should be upsampled to DSD.

Bruce, Roon is performing the headroom adjustment. The signal path indicates that. HQPlayer has no way to disregard that adjustment under Roon.


Good catch — completely missed that. @Bruce_Orr, just throw the master switch on the DSP Engine for your HQPlayer zone:

1 Like

Thanks Andrew. Does that imply Volume Leveling - if set on Roon - would also get applied and implemented despite HQP?

David/Lorin/Andrew - you guys are awesome. Beers all around if we can find a convenient bar! Anyone near Dallas?

So my report back on all the great coaching:
Note: Although DAC is DSD256 capable and I use an Ethernet/ultraRendu/USB Lush input, apparently because I use a Mac, 128 is the “real” limit. (I read lots of people are using MacMinis but I assume they must be putting Windows on it)

  1. When I select SDM/DoP only (no DSDFF DSF):
  • PCM files upsample to either 354 or 384 (limit)
  • DSD64 upsamples to 128; 128 stays the same; and 256 downsamples. All as expected!
  1. When both SDM/DoP and DSDFF DSF are active, everything is exactly the same Except DSD256 does not play at all. Roon’s dancing bars are active but not the progress bar (HQP). Not sure why 256 does not downsample.

  2. When SDM/DoP (no DSDFF) is active and SDM is selected on the HQP main page, all File types upsample to DSD. DSD256 downsamples to 128. As expected!

All this is great progress for me. I’m happy to be able to start enjoying!

Is there a difference between the DSD files that play in #1 vs #2?

If Headoom Mgt is disabled in Roon, is it needed in HQP? Or should it be left on in Roon?

In all alternatives above, volume volatility is great track to track. DSD in #2 was much louder than DSD in other alternatives as well as other formats. Can I confirm that in addition to no volume leveling is available in HQP, enabling it on Roon will have no impact? I ask because when Headroom Mgt was enabled on Roon it did have an impact.

Thanks guys!!