Issue ez-29: Text entry boxes render with unreadable giant text sometimes

Just chiming in; Have NOT seen this behavior…

I get this. Usually when editing track titles. Lenova Thinkpad E590, Windows 10. There’s a lot of things I don’t report about roon.

Hi @ezman & others who chimed in,

When this behavior next occurs, could you please note the exact local time + date of the occurrence, which page in Roon you were on and which Roon Remote you were using (or if it’s the Core UI directly)?
I can enable diagnostics for your account afterwards and perhaps we will get some more clues on in the logs.

@noris Will do. Does it matter to you if we report outside business hours?

Nope. The Roon rolling logs are persistent for some time, so as long as it’s reported within a week or so of it occurring, the older logs should still be present (the logs automatically get overwritten once they get filled up and overwrite starting with the oldest one).

This problem occurred today on my main server (rooncore in docker under unRAID) at 5:45PM.

The client is running under Windows 10 with a 4k monitor and 225% font scaling.

There was another behavior that I haven’t noticed before. When first entering the text, everything looked normal. As soon as I clicked on the input field, the text shrunk ever so slightly. After typing into the field and hitting return, the text was rendered very large. Interestingly, you can see the remnants of the very bottom of the glyph descenders “y” and “g” from the small rendering just below the truncated large “e” and “y” in the text “neil young”

I switched to my small server (rooncore on old NUC running windows 8) and observed the same large text at 5.58PM.

In this case, the text is rendered at normal size except when the textbox is selected, at which time the text enlarges. Here, the filter query is “the band”. The text doesn’t get smaller when clicked on the first time, it just jumps to the large size.

I did this one more time after changing window’s font scaling to 100%. I get exactly the same results with the two filter queries.

I don’t know if this info is useful to you, but I switched servers and transferred my license without restarting the windows client.

@noris, please let me know when you’ve looked at my log files and turned on debugging, and what the next step is.

1 Like

I am firmly convinced this is not a product of your Roon Core, but rather what you are using as Control. On which of your Controls are these screen dumps from? And if it’s a PC, what graphics card and driver are you using?

I agree that this looks like a client side problem. But roonlabs is asking to troubleshoot this way and I am following their lead.

Perhaps they’re doing some remarkable server-side rendering and roon remotes are very thin clients. Or perhaps the client can send extensive debug logging info to the server when enabled.

The laptop is this Asus model. The desktop pc has a GeForce NVIDIA GTX 960 graphics adapter driving a 4k Dell monitor. The iPad is an A1566 iPad Air 2.

It even happens using remote desktop. Yes, Dorothy, I’ve been able to run the roon client over remote desktop, but you have to start it on the remote pc before opening remote desktop on a client. Here’s an open support issue that I submitted about this two years ago.

Thanks! I will try this out on my own iPad Air 2, as i haven’t seen this.
However, i know of one view that has a strange behaviour which is similar to this, and thats on the login screen. (The one you see when attaching to a core which hasn’t got a valid license, and ypu need to get one from
When you type your mail address the type face is different from when you move to the password field, which causes the whole view to flutter.

I don’t recall if I’ve seen it on the login screen, but have seen it in many places. The screenshots have been of the album filter textbox i guess because I haven’t been using many other roon features lately.

Hi @ezman

Thanks for these timestamps! Just to confirm here, both of these timestamps were from the same Windows 10 client? I’m seeing a MALLARD2 Windows 10 Roon Remote associated with your account, can you confirm that this same remote was used in both instances?

I believe the issue is more-so related to the remote rather than the Core. The text rendering is done on the remote and the Core just manages the remote’s connection.

Yes. I switched between servers from this client on mallard2 without closing and re-opening the client.

1 Like

Thanks for clarifying that aspect @ezman! I can confirm that logs from both your Core and Remote have reached out servers and I have asked QA if they can take a look to see if there are further clues regarding the behavior. Once I have further information or questions, I’ll be sure to let you know!

I was encouraged that this would have been fixed when reading in one of the recent release notes that roonlabs worked on font scaling problems. For better or worse, this problem now always occurs reliably on the Windows 10 client, and I think on the iPad client too.

Now when I open the album browser, type a query into the filter(?) box (not the search popup), hit enter, review the albums, click on the filter box again, and BAM! Giant text.

Then, when I delete the giant text, hit [X], and then click on the now-empty filter box again and enter, the text I enter renders properly again. And becomes giant when repeating the sequence in the last paragraph.

Problem still persists here too!

Hi @ezman,

Thanks for the additional info!

Is the behavior still the same with 100% scaling on the new build? Can you please let me know a timestamp of when you reproduce the issue and which Core/Client was used?

Can you please share a screenshot of what this issue looks like on the iPad client?

The bug goes away at 100% (no) font scaling, though I need a magnifying glass to read the text on a 27" 4K monitor! :slight_smile:

The test was run about two minutes before submitting this message. The client is windows 10. Core is in a docker on a server running unraid.

1 Like

Thanks @ezman, I’ll note it in your ticket.
Next time you see this on iPad, can you please share a screenshot?

I most frequently saw this before in the text boxes for various DSP filter parameters on the iPad. I haven’t been able to reproduce this manifestation and the album filter box is working correctly on the iPad too.

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.