Issue in reproducing DSD files

Hello. I’m having issues in reproducing DSD 256 files purchased on Blue Coast. I’m using Nucleus streaming through a dCS Bartok (which perfectly supports these files), and the app loses connection with the server. Can you help? Thanks.

Set Roon DSP engine to convert DSD256 to DSD128.

1 Like

I’m getting the same error with DSD128 files. What am I doing wrong?

I am able to play DSD64 files but not DSD128. Why?

In order for Roon’s @support team to better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so they can have a clear understanding of how your devices are communicating.

I am using a Roon Nucleus connected via Ethernet. Audio device is a dCS Bartok. Here is a screenshot of the Bartok settings.

Here is a screenshot of Roon

I’m anke to play native DSD 64 but not DSD 128 files. What am I doing wrong? Thanks.

Update: I can play the DSD128 file through the Bartok without Roon. So this must be a wrong setting in my Roon setup. Can you please help? Thanks.

Anybody can help? Thanks :pray:

@support can you please help? Thanks. F.

I think I’ve solved it by desabling “Native DSD Processing”!

That only affects how Roon transcodes files when necessary.
What is your Roon Server/Core and how is this connected toyour Bartok? Please describe your system!

Roon Nucleus connected via Ethernet. DAC/Streamer is dCS Bartok connected via ethernet.

Try turning off volume levelling and convolution and see if it works.

I’ve solved it by desabling “Native DSD Processing”!


Okay, i understand now what’s going on. You are trying to process DSD128 and DSD256 by applying convolution filtering and other DSP-manouvers with a Nucleus Core. The Nucleus (standard issue i3) is not fit for heavy duty DSP with DSD-media. As you can see in the latest screenshot, the processing speed in that situation is 1.5x, which means you are on very edge of what it can do.
You can consider the processing speed figure as an load indicator, it should never drop below 1.5x and preferably not below 3.0x

If you really need/want to apply DSP processing in real time to very high rez files, particularly DSD files, you need more muscle in your Roon Core, an Intel Core i7 at the very least.

IMO the whole point of purchasing High Rez DSD material is to pass them on untouched to the DAC, this can be done without issues with your Core, simply disable any DSP.

Thanks Mike. As I said, I solved it by desabling the “Native DSD Processing” toggle. Processing speed in playing DSD128 was 4.5x. Is that ok? Thanks.

Absolutely, that will be fine. As I said though, you’ll likely find the high rez tracks sounding the very best untouched by Roon DSP, but of course there still may be reasons to use DSP.
Why I dislike " Disable Native DSD-processing" is the fact that you transform the files into PCM and then back again, which to me makes the DSD files loose their advantage over high rez PCM.

What I’m saying here is that heavy DSP’ing really doesn’t fit DSD material, and is better suited to PCM media.

1 Like

Thanks Mike. I’m using HAF filters for room correction and I really love them. I’ll ask the HAF guys about this.