Issue loading the database

Roon Core Machine

Linux, Slackware, Intel(R) Core™ i3-4130T CPU @ 2.90GHz, 4 cores, 8GB RAM

Networking Gear & Setup Details

Wired ethernet

Connected Audio Devices

No audio devices connected on server

Number of Tracks in Library

I can not see that because the database won’t load

Description of Issue

After a server reboot this morning I get the error “There was an issue loading the database” on starting up the Roon app on my ios devices.

The following packages where upgraded this morning:

ap/vim-8.2.3754-x86_64-1.txz: Upgraded.
d/Cython-0.29.25-x86_64-1.txz: Upgraded.
d/rust-1.57.0-x86_64-1.txz: Upgraded.
kde/kscreen-5.23.4-x86_64-2.txz: Rebuilt.
kde/libkscreen-5.23.4-x86_64-2.txz: Rebuilt.
l/glib-networking-2.70.1-x86_64-1.txz: Upgraded.
l/imagemagick-7.1.0_17-x86_64-1.txz: Upgraded.
l/vte-0.66.2-x86_64-1.txz: Upgraded.
n/dovecot-2.3.17.1-x86_64-1.txz: Upgraded.
xap/mozilla-firefox-91.4.0esr-x86_64-1.txz: Upgraded.
xap/vim-gvim-8.2.3754-x86_64-1.txz: Upgraded.
a/hwdata-0.354-noarch-1.txz: Upgraded.
a/sysklogd-2.3.0-x86_64-1.txz: Upgraded.
kde/breeze-icons-5.88.0-noarch-2.txz: Rebuilt.
l/netpbm-10.96.04-x86_64-1.txz: Upgraded.
l/python-charset-normalizer-2.0.9-x86_64-1.txz: Upgraded.

Are there any packages with a relation to Roon ?

Everything seems to be running on the server:

ps -xa | grep -i roon

27561 pts/1 S+ 0:00 -su /opt/RoonServer/start.sh
27577 pts/1 Sl+ 0:00 /opt/RoonServer/RoonDotnet/RoonServer RoonServer.dll
27598 pts/1 SLl+ 0:45 /opt/RoonServer/RoonDotnet/RoonAppliance RoonAppliance.dll -watchdogport=46163
27600 pts/1 S+ 0:00 /opt/RoonServer/Server/processreaper 27598
27729 pts/1 Sl+ 0:01 /opt/RoonServer/RoonDotnet/RAATServer RAATServer.dll

tail -f RoonServer_log.txt:

12/08 11:09:52 Trace: [roonapi] [apiclient 192.168.1.1:45784] CONTINUE Changed {“message”:“Extension Repository loaded”,“is_error”:false}
12/08 11:09:57 Info: [stats] 23719mb Virtual, 1626mb Physical, 271mb Managed, 228 Handles, 71 Threads
12/08 11:10:12 Info: [stats] 23719mb Virtual, 1626mb Physical, 271mb Managed, 228 Handles, 71 Threads
12/08 11:10:27 Info: [stats] 23510mb Virtual, 1627mb Physical, 271mb Managed, 228 Handles, 41 Threads
12/08 11:10:42 Info: [stats] 23510mb Virtual, 1627mb Physical, 272mb Managed, 228 Handles, 41 Threads
12/08 11:10:52 Trace: [roonapi] [apiclient 192.168.1.1:45784] CONTINUE Changed {“message”:“Extension Repository loaded”,“is_error”:false}
12/08 11:10:57 Info: [stats] 23743mb Virtual, 1627mb Physical, 273mb Managed, 228 Handles, 74 Threads
12/08 11:11:12 Info: [stats] 23743mb Virtual, 1627mb Physical, 273mb Managed, 228 Handles, 74 Threads
12/08 11:11:27 Info: [stats] 23510mb Virtual, 1627mb Physical, 273mb Managed, 228 Handles, 41 Threads
12/08 11:11:42 Info: [stats] 23510mb Virtual, 1627mb Physical, 274mb Managed, 228 Handles, 41 Threads
12/08 11:11:52 Trace: [roonapi] [apiclient 192.168.1.1:45784] CONTINUE Changed {“message”:“Extension Repository loaded”,“is_error”:false}
12/08 11:11:57 Info: [stats] 23542mb Virtual, 1627mb Physical, 274mb Managed, 228 Handles, 49 Threads
12/08 11:12:12 Info: [stats] 23542mb Virtual, 1627mb Physical, 275mb Managed, 228 Handles, 49 Threads

RaatServer_log.txt
cat RAATServer_log.txt
12/08 10:14:26 Info: Starting RAATServer v1.8 (build 850) stable on linuxx64
12/08 10:14:26 Trace: [RAATServer] detected ALSA support
12/08 10:14:27 Debug: [easyhttp] [1] POST to https://bits.roonlabs.net/1/q/roon.base.,roon.internet_discovery. returned after 630 ms, status code: 200
12/08 10:14:27 Trace: [bits] updated bits, in 702ms
12/08 10:14:27 Info: [RAATServer] creating RAAT__manager
12/08 10:14:27 Info: [RAATServer] appdata_dir = /root/.RAATServer
12/08 10:14:27 Info: [RAATServer] unique_id = 782ec47d-6e29-4d16-afc0-b31c701d3b65
12/08 10:14:27 Info: [RAATServer] machine_id = 1425a6e3-4f5e-f889-9442-4010826a4469
12/08 10:14:27 Info: [RAATServer] machine_name = ha********** (edited)
12/08 10:14:27 Info: [RAATServer] os_version = Linux 5.15.6
12/08 10:14:27 Info: [RAATServer] vendor =
12/08 10:14:27 Info: [RAATServer] model =
12/08 10:14:27 Info: [RAATServer] service_id = d7634b85-8190-470f-aa51-6cb5538dc1b9
12/08 10:14:27 Info: [RAATServer] is_dev = False
12/08 10:14:27 Trace: [raatmanager] starting
12/08 10:14:27 Trace: [raatmanager/linux] FOUND id=hw:CARD=HDMI,DEV=3 usb_id=
12/08 10:14:27 Trace: [raatmanager/linux] vendor= name=HDA Intel HDMI 0
12/08 10:14:27 Trace: [raatmanager/linux] FOUND id=hw:CARD=HDMI,DEV=7 usb_id=
12/08 10:14:27 Trace: [raatmanager/linux] vendor= name=HDA Intel HDMI 1
12/08 10:14:27 Trace: [raatmanager/linux] FOUND id=hw:CARD=HDMI,DEV=8 usb_id=
12/08 10:14:27 Trace: [raatmanager/linux] vendor= name=HDA Intel HDMI 2
12/08 10:14:27 Trace: [raatmanager/linux] FOUND id=hw:CARD=PCH,DEV=0 usb_id=
12/08 10:14:27 Trace: [raatmanager/linux] vendor= name=HDA Intel PCH ALC887-VD Analog
12/08 10:14:27 Trace: [raatmanager/linux] FOUND id=hw:CARD=PCH,DEV=1 usb_id=
12/08 10:14:27 Trace: [raatmanager/linux] vendor= name=HDA Intel PCH ALC887-VD Digital
12/08 10:14:27 Trace: [raatmanager] initialized
12/08 10:14:27 Info: [RAATServer] running RAAT__manager
12/08 10:14:27 Trace: [raatmanager] starting discovery
12/08 10:14:27 Trace: [discovery] starting
12/08 10:14:27 Info: [discovery] [iface:lo:127.0.0.1] multicast recv socket is bound to 0.0.0.0:9003
12/08 10:14:27 Info: [discovery] [iface:lo:127.0.0.1] multicast send socket is bound to 0.0.0.0:41607
12/08 10:14:27 Info: [discovery] [iface:eth0:192.168.1.1] multicast recv socket is bound to 0.0.0.0:9003
12/08 10:14:27 Info: [discovery] [iface:eth0:192.168.1.1] multicast send socket is bound to 0.0.0.0:43517
12/08 10:14:27 Info: [discovery] [iface:br-4a8ace05b504:172.28.0.1] multicast recv socket is bound to 0.0.0.0:9003
12/08 10:14:27 Info: [discovery] [iface:br-4a8ace05b504:172.28.0.1] multicast send socket is bound to 0.0.0.0:35343
12/08 10:14:27 Info: [discovery] [iface:docker0:172.17.0.1] multicast recv socket is bound to 0.0.0.0:9003
12/08 10:14:27 Info: [discovery] [iface:docker0:172.17.0.1] multicast send socket is bound to 0.0.0.0:33140
12/08 10:14:27 Info: [discovery] unicast socket is bound to 0.0.0.0:9003
12/08 10:14:27 Trace: [raatmanager] starting server
12/08 10:14:27 Info: [jsonserver] listening on port 9200
12/08 10:14:27 Trace: [raatmanager] announcing
12/08 10:14:27 Debug: [discovery] broadcast op is complete
12/08 10:14:27 Trace: [inetdiscovery] added device raatserver/782ec47d-6e29-4d16-afc0-b31c701d3b65 in addr:ADDR
12/08 10:14:27 Trace: [inetdiscovery] added service com.roonlabs.raatserver.tcp for device raatserver/782ec47d-6e29-4d16-afc0-b31c701d3b65
12/08 10:14:32 Trace: [ipaddresses] enumerating addresses
12/08 10:14:32 Trace: [ipaddresses] FOUND lo 127.0.0.1
12/08 10:14:32 Trace: [ipaddresses] FOUND eth0 192.168.1.1
12/08 10:14:32 Trace: [ipaddresses] SKIPPED eth1: no ipv4
12/08 10:14:32 Trace: [ipaddresses] FOUND br-4a8ace05b504 172.28.0.1
12/08 10:14:32 Trace: [ipaddresses] FOUND docker0 172.17.0.1
12/08 10:14:32 Trace: [ipaddresses] SKIPPED vethf0d32ea: no ipv4
12/08 10:14:32 Trace: [ipaddresses] SKIPPED veth488f2fc: no ipv4
12/08 10:14:32 Trace: [ipaddresses] SKIPPED veth5cd2ea3: no ipv4
12/08 10:14:32 Trace: [ipaddresses] SKIPPED vethe6d937c: no ipv4
12/08 10:14:32 Trace: [ipaddresses] SKIPPED veth6a49edd: no ipv4
12/08 10:14:32 Trace: [ipaddresses] SKIPPED veth6de860e: no ipv4
12/08 10:14:33 Debug: [easyhttp] [2] POST to https://discovery.roonlabs.net/1/register returned after 322 ms, status code: 200
12/08 10:14:33 Trace: [inetdiscovery] registered 1 devices, 1 services
12/08 10:14:37 Trace: [RAATServer] refreshing @ 10s
12/08 10:14:37 Trace: [raatmanager] announcing
12/08 10:14:38 Debug: [discovery] broadcast op is complete

Output start.sh
00:00:00.000 Warn: get lock file path: /tmp/.rnsgem0-
Initializing
Started
aac_fixed decoder found, checking libavcodec version…
has mp3float: 1, aac_fixed: 1
Running

I’ve got no idea of what went wrong ! Please help !

Best regards,
Lars

Maybe this helps:

1 Like

Yes, that was it ! Thanx for the tip !

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.