Issue loading your library - backups not working

Roon Core Machine

NUC i7 running ROCK only, latest version 1169
Storage on Synology NAS, wired, no config changes

Networking Gear & Setup Details

All wired ethernet, no config changes in the past several months

Connected Audio Devices

Grimm MU1 as roon endpoint, latest firmware, no config changes in the past several months

Number of Tracks in Library


Description of Issue

2 days ago, I got the ‘Issue loading your library’ error message when launching Roon on my laptop. I restored from a recent backup and everything was fine. I was able to play music and add new items to the library.
This morning, I get the same error message and this time, when I point to a backup to restore from, nothing happens. The message ’ there was an issue loading your library’ stays up and nothing else.

update: I restarted ROCK on the NUC and got the message ‘this new version of Roon requires a database update pls be patient’. Now I have my library back, including some files I added to the NAS this morning. Will force a fresh backup as soon as it is done scanning (little blue circle, top right).

The library is once again available and updated in terms of content.
NOW: I want to do a backup. The screen message ‘snapshotting your database - this may take a while’ appears for 1 second and then I get the turning circle ‘waiting for Roon Core’, followed by ‘Uh-Oh, something’s wrong - select different core’
I go through the select core procedure. My NUC/ROCK shows up as Green and the process starts all over.

So I cannot run a backup at this point.

Update 3: I have since done a full, hard reboot of the Core and can still access all my music but backup continues to fail.
I get to the ’ snapshotting’ message for a couple of seconds and then it switches to the blue circle / waiting for Roon Core / uh-oh something’s wrong.

If I then close out the app on my laptop and go back in, it shows it has lost contact with the Core and the core shows up as red / ’ connecting…’
I can still browse to the ROCK Core, so I know it’s up and available.

Can you check that your Backup location settings in Roon are still valid by opening the “Choose folder to backup to” screen to see if it’s still accessible?

Yes it is. I have to point to that location when I try to do a manual back-up.

In order to restore connection to the ROCK / CORE, I have to restart the server software on ROCK and then it reverts back to ‘green’ i the Roon app but if I then try another manual backup, the whole thing starts over.
I just created a new folder to back up to, inside the Roon app. Same error as soon as I start the manual backup process to this new folder.

Can you post a screenshot of that location screen? Thanks

Here are 3 screenshots: 1. the overall location / directory 2. the old folder roonbackups 3. the new folder inside roonbackups2

You seem to be putting your Backups inside a Watched Folder (\\\music)? If so, this is wrong. Backups should be held elsewhere.

I will try that, but to be fair: this worked perfectly until just 3 days ago…

Just tried that. Created a new folder at the root of Diskstation. Got the exact same error. 2-3 seconds of ‘snapshotting’, then the ‘waiting for core’ followed by ’ uh-oh…’

Then the connection to the core is lost . On the NUC, I see the yellow activity light going like crazy but nothing else happens until I break the process by restarting the server.

By leaving everything alone, it appears that , after quite a while, Roon re-establishes connection with the Core and the backup finally started (currently 37%).

Backup successfully completed. I guess patience was required and it sorted itself out. This is a foreign concept to me, as I just assumed it crashed when it threw the ‘uh-oh’ error . Thanks to @Geoff_Coupe for the inputs.

You have a large number (570,000) tracks in your library, perhaps this is why your Roon client loses contact temporarily with your Core on your ROCK/NUC.

I am not seeing this on my setup, but then I have only 61,340 tracks in my library.

Please keep the Backup location outside of your Watched Folders - see the warning in the Help article on Backups:

1 Like

Noted and thanks again

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.