Issue playing DSF Multichannel

Hello @support,

New to Roon – still on my trial membership and very excited so far for everything this great piece of software does.

However I’m facing an issue that I hope you can help me with. I’ve started ripping some SACDs and exploring how Roon deals with them. I’ve been able to successfully play 2-channel DSF files, however the multi-channel ones don’t work. Roon just skips through all the tracks in the album really fast and stops when reaching the end with no error message.

Here’s my setup and some screenshots of how I’ve configured my endpoint.

Roon v. 1.5 build 339 64 bit
Windows 10 64 bit
Processor AMD A8-3850 APU with Radeon™ HD Graphics, 2900 Mhz, 4 Core(s)
Library is stored locally and is about 3,500 tracks at the moment
Denon RSX-1560 receiver through HDMI

The albums that fail are DSF/DSD64 5.0

I’m attaching the device properties as reported by Windows, and the Roon setup screens. Hope this is enough info to get the conversation started :slight_smile: Thanks!


Try setting 7.1 channel layout. See if it behaves differently.

It does behave differently! But still doesn’t work. Instead of skipping over the tracks, I get an error message that says “Transport: Failed to initialize the audio device”.

Hello @Miguel_Rode,

Thanks for contacting support, I’d be happy to take a look over this issue with you. I have a few suggestions:

  • Can you please let me know if checking the option “Workaround devices that misreport capabilities” has any impact on the ability to play those files?
  • Are you able to play those files to any of your other zones (such as the internal speakers of the computer)?
  • Also, would you be comfortable with sharing a few of those files with us just so that we can verify if they are able to play on our end? I will PM you a message on how to upload files for analysis to our servers shortly.

Please let me know your findings when possible and we can continue from there.


Hi @support -

Well, your first try did it! The “misreported capabilities” switch solved the problem. I’m surprised, since per my first screenshot above, Windows seems to be reporting the device’s capabilities correctly. What could be being misreported?

Also here’s another little mystery. As you can see, the signal path shows that Roon is downsampling to 176K and converting to 16 bit, even though the device is configured up to 192K/24bit. And I’m positive that the receiver can in fact handle that resolution since JRiver uses it. Any clues?

In any case - thanks a lot for your help. Happy to be able to play multichannel!


Roon will downsample in the correct multiples so as it is a multiple of 44.1 then the highest will be 176. I would expect your device to work at 24 bits so perhaps Roon is just in compatibility mode.

Thanks, Henry. What is compatibility mode?

Hello @Miguel_Rode,

Glad to hear that the compatibility switch resolved the issue!

The thing that could be misreported here is the device’s channel support by the device itself. You seem to be streaming a 5 channel DSF file and using the “official” protocol for some devices, they only report supporting 2 channels (stereo) or 8 channels (7.1) and nothing in between, even when they actually do support other amounts of channels such as 6 channels (5.1). Hope this helps!


Interesting, thanks @noris. And why would Roon convert the bit depth from 64 down to 16?

Hello @Miguel_Rode,

I asked our tech team why it would convert the bit depth and they said that it seems to be with the way the audio is passed by the driver. They have asked if you can please try turning on the toggle that says “Enable Event Mode” and disable the “Misreported Capabilities” toggle to see if it now uses the correct bit-rate. Event Mode is a different way of communicating with the audio driver and should have better results. Please let me know if that works.


@noris, enabling Event Mode brings the original problem back (Roon skipping rapidly through the tracks), no matter whether Misreported Capabilities is on or off. So I turned it back off.

Let me know if you have any other ideas regarding the bit depth. I just noticed that if I limit the sampling rate to “Up to 96kHz”, then Roon converts to 88.2 kHz/24 bits. Moving the setting back to “Up to 192kHz” makes it use 176.4 kHz/16 bits.


24/88 isn’t going to be any worse than 176 at 16 bits. It might even be better.

Hello @Miguel_Rode,

Sorry to hear that Event Mode didn’t help here. We have a developer on vacation this week, but I’ll discuss this case with him next week and see if there’s anything we can do. It’s possible this device is misreporting it’s capabilities to us, but I’d like to confirm with the technical staff before making a suggestion. I will be sure to update you on next steps once we have consulted with our developer.


I realize that, and I don’t disagree. However I’m curious why Roon can’t take advantage of the full 24/192 (or 24/176) that the receiver is capable of. Let’s see what support says if they’re willing to investigate.

Thanks, @noris! Keep me posted.

1 Like

Hi @noris, do you have any updates from your developer on this issue? Thanks!

Hello @Miguel_Rode,

I have just had a chance to speak to one of our senior developers regarding your case and they have noted that the bit-depth and bit-rate limit is very likely attributed to the codec on the HDMI itself.

There have been similar reports of Intel HDMI out having these limitations and the dev believes that you are experiencing related behavior. Some users have had luck by rolling back the drivers, but those have been for Intel boards and not AMD such as your case.

Keep in mind that rolling back may carry some risk but you can read the report here and decide if it’s worth the risk or not:


Ok, thanks, @noris. I’ll do some investigation. It may be time to upgrade my audio card which is fairly old.

I went through the same odyssey as it seems that you are and I eventually went for a NUC running ROCK. It has been a great solution for a multichannel endpoint. Because it runs ROCK, you are using Linix device drivers and they don’t have the issues that you are experiencing. You can use a pretty bare-bones NUC like an I3 and it can run fan-less is you put it in the right case. You might even find it lower cost than a higher end video card.

Good luck.

1 Like