Issue running easy install on

Old Dell Intel based Desktop with 4GB Ram

Hi I am trying to re install my Roon core on Linux. I have installed Ubuntu 18.04.3 server. I believe that I have run all of the dependencies ok. When trying to download the easier installer script I am getting an error message (from scrolling back up the CLI) “This package is intended for $arch platforms. It is not compatible with your machine. Exiting” If I then try to run the install I get a “no such file or command” I I tried a fresh install of Debian as well and got the same issue. Am I doing something daft here?

Welcome to the forum, @Michael_Turner1!

Can you execute the following command from the shell and post the output. Thanks.

uname -a

Sure its Linux “rooncore 4.15.0-70-generic #79-Ubuntu SMP Tue Nov 12 10:36:11 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux”

Would the fact that the system time is wrong potentially cause the issue?

Ignore that. I just checked the timezone and its all correct. I am guessing that’s the date of the Linux Package and not the system time? Face Palms!

I wanted to confirm your machine architecture, but this is fine–Roon Server only runs on x86_64 platforms.

These are the steps you should follow:

sudo apt install curl ffmpeg libasound2 cifs-utils
curl -O
chmod +x
sudo ./
sudo systemctl status roonserver

If you repeat this and still get an error please post the output.

chmod: cannot access ‘’: No such file or directory

all of the other dependencies run fine and confirm that the latest version is already installed.

If you cd ~ to your home folder and download the file curl -O ... (that’s capital O not zero) and ls id the file present?

1 Like

Capital O not Zero!!! Thats what i have been doing wrong I think. Thanks so much for your help Martin. I guess the best way learn Linux is to throw yourself in the deep end right!!

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.