Issue trying to run two RoPieee endpoints concurrently

Core Machine (Operating system/System info/Roon build number)

Intel NUC NUC7i5BNH running Version 1.7 (build 610) stable ROCK software

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Ethernet

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Two Ropieee end points both with Raspberry Pi 3 Model B Rev 1.2 boards. One with HiFiBerry DAC+ light HAT the other with HiFiBerry DiGi+ HAT, both running Ropieee 2.596. Both boards connected via Wi-Fi but issue still occurs if wired connection used.

Description Of Issue

Hi have just recently purchased Roon and starting to look at setting up before implementing installation into the house.

I am trying to use both RoPieee devices in Roon but only one device is seen at a time in Roon!
I can have both RoPieee devices powered up and I can log into both via their ip address. However Roon will only show one device at a time not both! So for example with both devices powered up Roon only displays device 1 in audio section under settings. If I then power down device 1 then device 2 will appear in Roon. I can then power on device 1 again and only device 2 still shown in Roon. If I then power down device 2 then device 1 then appears again in Roon.

I did not clone SD when setting up second device in information section of Ropieee interface two different Board Serial ID’s are shown.

Any suggestions would be greatly appreciated, really hoping that this will work.

Thanks in advance

Ian

Update…

I tried all weekend to get both endpoints working in Roon and then this morning in the Roon control software I went into ‘settings > About’ and noticed both end points! Then went to ‘Settings > Audio’ and both devices were listed!

Really not sure what happened but glad that both seem to be working. Both show version 1.7 (build 571) stable.

With trepidation I did a power cycle of both end points and they both came back in Roon!

You can’t clone ssd card installs in case that’s what you had done. You should flash a new card and complete a full installation startup for all RPi units

Dear Wizardofox

Many thanks. I had read about NOT cloning SD cards so I did not do that, I did a new installation on the second RPi unit.

Ian

Rebooting both RPi’s and your router would probably have solved a problem such as this.

Hi @Ian_Foulger,

Welcome to the forum! I’ve shifted your post over to the #audio-products:ropieee section.

It sounds like the issue is resolved, but if you have any further difficulties, just let us know!

@Ian_Foulger,

As you have 2 RoPieee endpoints… have you changed the hostname of one of them?
Otherwise this could potentially confuse your router.

You can do this in the web interface.

Thanks

Just a final sit rep. I was still experiencing issues of RoPieee’s sometimes being there and other times not! This is probably a rookie error, but I noticed the yellow lighting bolt on the screen when Ropieee devices were first booting. This is showing insufficient power. I was using an adapter with dual output, one rated at 2.1A the other at 1.0A. So I ordered and received some 3.0A PSU’s today and all working correctly. I thought that I would mention resolution in case other beginners like me had a similar issue. Thanks again for all advice :grinning:

2 Likes

The ropieee 7” screen can be a big drag on power. Do also note that the rpi3 power connection is actually only rated at 2.5A max so adding the display and using the additional power the display gives you might be a good option to host the available power supplied.

I have two RPi4’s, one of which I use as a portable device with a Dragonfly Cobalt DAC and a screen. It is powered with an Anker battery which last for days. I use two separate wires from the battery to the screen and RPi4. PS: I am able to group the two RPi4’s together in a zone and play to both simultaneously.

1 Like

Many thanks. I am just using the Pi with a Digi+ Hat on. They are going to be end points sitting in a cupboard plugged into my amplifiers so power should be OK.

1 Like