Issue using Chromecast with Roon [resolved]


Roon was working perfectly for me until today.

I cannot use Roon to listen to music on any of my Google Cast devices (Google Home, Google Home Mini, Chromecast) anymore. I have tried restarting everything including my server and networking equipment. I still keep getting the following in the log:

Error: [cast/client] [CastReceiverChannel] Failure to start application 6242A3BE on device: {
“reason”: “CAST_INIT_TIMEOUT”,
“requestId”: 1155,
“type”: “LAUNCH_ERROR”

Interestingly, Roon connects to the Google Cast device and I can control the volume for example. What does not work is queuing a song to play.

Any idea of what might be happening?


PS: Roon works well when playing music on my Mac directly.

Support staff response (edited for visibility):



Same problem here.

Just tried my system which uses Google Chromecast, and when I attempt to play music (using either my iPad or Windows PC as Roon Control) the play function simply doesn’t work. No message - just doesn’t do anything.

Roon still works on my Linn Klimax DS/1 and Sonore microRendu/Mytek Brooklyn+ based systems, and on my Muso Qb (over wi-fi).

Same here. Chromecast Audio, firmware 1.42.172094, country code US. Get the bleep at the start, then error, “audio device refused to switch input to roon”. Power-cycling doesn’t help.

@support, help!


Same problem here. Music doesn’t play through Chromecast anymore. I does play through my BlueSound Node2, of course, but I get a black screen with an empty picture placeholder. @support

I use chromecast in display. Doesnt work anymore.
Believe its the same problem as mention above regarding playing.

1 Like

My 11 year old daughter is seriously pissed now as she can’t listen to Billie Eilish under the shower…
@support this is an emergency :slight_smile:


Same here, I made another post about it before.
Did we receive a patch?

1 Like

Same here and manifests itself in precisely the same way as everyone else here. What the hell happened?

Also I tried disabling my network devices on my Roon Core and now they will not re-enable.

1 Like

This happens to me from time to time and usually restarting Roon and/or Chromecast Audio makes everything happy.

Not this time

Doesn’t work for me either.

Never had any similar problems before that I know of, although I use my Chromecast based system much less than my others.

This is a far more significant and seemingly widespread issue that started today.

@support Broken for me as well. I get “Audio Device refuses to switch input to Roon” message. I’ve got a core installed on Mac OS 10.14.6. Plays fine if playing direct to DAC hardwired to computer. I’ve tried restarting all Chromecasts, computer, and router. I have also disabled and Chromecast devices under Roon output settings and can no longer enable them.

1 Like

Hi everyone — We are investigating this with our technical team and we will be sure to update you as soon as possible. Your reports are much appreciated, and you have our apologies for the trouble!


I’ve got three Chromecast Audio acting as main roon endpoints. This certainly is a problem because I have been moving old Sonos zp 80s out after getting so hacked off with that Company’s recent shenanigans.

1 Like

Core Machine (Operating system/System info/Roon build number)

Win10 Desktop I7, 16GB Latest Roon version

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

TP Link accesspoint wired to provider router. All cat 6 cables

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Cambridge Audi CNXv2, Polk Audio Magnify Mini, Google Home Hub

Description Of Issue

Since today, nothing changed as far as I know, none of the devices connected with wifi wil play. Roon says the device is not allowing to connect or something like that. The devices play fine when I connect directly from Qobuz, Spotify or Jazzradio.
I disabled the Cambridge Audi streamer and now I cannot enable it anymore. I click the enable button and nothing happens. Roon will play on the speakers of the core machine. And I can play to the core machine from my phone.

1 Like

I just checked and I can access the CA with Airplay but not wifi.

It’s Chromecast that’s not working anymore.
I have 3 chromecast devices and none of them connect.

1 Like

I’m having EXACTLY the same problem. Everything worked last night and now today, none of my network devices (Chromecasts and Shield) will play.

I’ve cold booted everything and checked connectivity and other apps for casting. Everything seems to work except Roon. It will not play to anything other than physically connected audio device.

I was literally about to blow out my Core and re-install as I’m at a loss as to what else to do. Glad I saw this post.

Wondering how this could happen as a widespread issue. Did Roon software or Chromecast firmware change over night?