Issue with Channel Mapping for 2-way Convolution Crossovers (ref#APX2OY)

What’s happening?

· I'm having trouble with my DAC, speakers, streamer, etc.

What best describes the issue with your audio device?

· Other

Describe the issue

Channel mapping problem with 2way convolution crossovers.
My system is Roon on a windows laptop -> USB connection to Okto 8 channel DAC -> active 2way stereo speakers. I have built the 2way digital filters in acourate, and acourate writes the cfg files and generates a Roon style zip file that Roon loads successfully. Note these filters have been tested in JRiver and work correctly.
My expectation was that in the audio setup for that zone I would just choose the 7.1 option to match the 8 channels available on the DAC, and use "Channel Mapping Only" to get the 4 channels processed by the convolution filter to map to channels 1 to 4.
However, when I run this setup, the DAC only receives 3 channels of information as shown by the channel display on the DAC and no output on the right tweeter.
When I check the signal path it states that the convolution step is processing 4 paths.
To do some testing - I added a procedural EQ step after the convolution, selected mix and sent channel 3 out on channel 4 and I now get 4 channels received on the DAC and hear the left channel treble coming out of both the left and right tweeters. So I'm comfortable the filter files are correct, and the laptop is driving the DAC correctly (as confirmed in Jriver)
Is there a step I've missed here?

Describe your network setup

Not relevant

Hi @Nick_Holroyd ,

Thanks for reaching out. Can you please share a few screenshots of the behavior you see on your end, along with the Signal Path that Roon is displaying?

Hi Norris, thanks for jumping on the thread.
So with only 3 channels of output (=left bass + right bass + left treble) the Muse interface looks like:


and the signal path shows:

Thanks Nick

let me know if you you’d like the filter file.
Thanks again
Nick

And @noris if I enable this ProceduralEQ mix filter I get 4 channels at the DAC outputting:
1 = left bass
2 = right bass
3 = left treble
4 = left treble routed to the right tweeter

@noris any other diagnostics I can run for you?

What’s happening?

· Something else

How can we help?

· None of the above

Other options

· Other

Describe the issue

A week with no support?

Describe your network setup

Not applicable

Please don’t open duplicate support requests. It doesn’t help you or the Support team. Thank you.

Thanks for your interjection, Geoff.
But to be accurate one is a support question, and one is a legitimate complaint from a customer lodged with a company whom I pay for a commercial product. Roon choose to air this laundry on a public forum.
So now, as a user who has been onboard since Roon’s inception, has evangelised the product and company, loved that you could chat with Danny et al on this forum, and cheered their success, I’m lamenting the lack of available support.
Regards
Nick

Complaints should be made in the Feedback category of the forum, not the Support category. There are four people in the Support team; they have a queue, and it’s also a holiday in the US. Thanks for your understanding.

Hello @Nick_Holroyd ,

Thanks for the additional details and your patience here. Your report looks similar to an existing ticket, and I am not sure the Convolution is playing a part here. If you try to disable the Convolution filters and use the same channel mapping, are you still able to reproduce the same issue?

I’ll test it this weekend and will report back.
I’ll also try a work around of creating 3 way x-overs with the upper x-over at 22kHz to a non-existent super tweeter. Then if the 6th channel disappears in the same way the 4th channel is now missing then the system will still be fully functional.
I’ll also see if any alternate configurations change the behaviour. i.e. is this is an issue with Roon moved to a linux box and any difference playing direct from the server’s USB or sent across the network to a microrendu etc.
@noris Does the open ticket have any further details on work arounds tried, OS specifics etc?
Thanks N.