Issue with Connecting Roon ARC to Roon Server (ref#AB3CHY)

What’s happening?

· I'm having trouble with Roon ARC

What best describes your issue with ARC

· I can't log into ARC but I can log into Roon

Describe the issue

I have set up two methods to connect to Roon ARC.

1. set port forwarding in the router. The same ports are specified in the router and in the Roon settings. Roon gives me its OK: "Ready. Roon ARC can securely access your Roon server". However: Roon ARC cannot connect to the Roon server while on the move. I have even tried changing the port numbers to 60000.
2. the second method is the one that is also described on the help pages: I have installed tailgate on both the iPhone and the Roon server. Even with this method, Roon ARC cannot connect and indicates a port forwarding issue as an error message. I tried deactivating port forwarding in the router and tried tailgate alone (I didn't know whether these two methods would get in each other's way), but that didn't work either.

My internet connection works in principle. For example, I can access my music library on the Synology via Plexamp when I'm on the move. But that's not the real thing... ;-)

Roon Server 2.0 (build 1413)
Roon ARC 1.9.53 (build 272)
Roon Server lives on a Synology NAS with DSM 7.2.1-69057 Update 5

Describe your network setup

Router: FRITZ!Box 5590 Fiber, connected to a fiber optic line (FTTH), provider is Deutsche Glasfaser. The Synology is connected to the Fritz!Box via LAN.

1 Like

Hello @Holger ,

Thanks for reaching out. Can you please confirm, if you temporarily host your Roon Server on a PC, do you experience the same issue there, or is it limited to the Synology server only?

  • Create a Backup of your current database
  • Open Roon on the other PC you wish to try running as your Roon Server
  • Roon Settings → General
  • Disconnect
  • On the “Choose your Roon Server” screen, press “Use this PC”
  • If asked to Unauthorize, you can go ahead and do so. You are limited to one active Roon Server at a time but you are free to switch between them as often as you’d like
  • Verify if the same behavior occurs on the different PC

Hello @noris ,
thanks for your suggestions.
Short answer: Yes, with Tailscale it works with Roon Server on the Mac.

Here comes the details:
I have set up my MacPro as a Roon server and, although not my entire library, I have given it a few albums to test.

The configuration via my router using port forwarding did not work (“MultipleNatFound”). However, this is only a temporary problem, as the router is currently not connected directly to the fiber optic cable, but to a converter via LAN cable that converts the light signals into power signals. My provider is working on a solution.
What is much more interesting, however, is that I can access my MacPro with the Roon server via Tailscale and Roon ARC when I’m on the move - so it works in principle. I would even prefer remote access via Tailscale than via port forwarding.

Now I’m wondering why it doesn’t work via tailscale with the Roon server on the Synology, as I described in my initial post. In principle, the network connection is established – Plexamp can access the music library on the NAS via Tailscale while on the move. Roon ARC is obviously a bit more selective. The same recent version of Tailscale is installed on all devices involved (Synology, MacPro, iPhone): 1.68.1. On the iPhone only 1.68.0, and I am not offered a more up-to-date version.

What can I do now, should I leave this installation as is for further testing and experimenting, or can I switch back my Roon server on the Synology with whole my music?

Can confirm I’m having the same issue running on an updates synology server as well. This was not a an issue prior to the latest update build 1432
@noris

Hi @noris
any news with this issue? Are there other Synology use having this problem?
Using Roon without ARC is only half the fun…

Hi @Holger / @Justin_McMurdo ,

Is RoonServer by any chance installed in a Docker container on your Synology? Or is it installed as a native app?

Hi @noris ,
I used the installer from @crieke and installed Roon as a normal app on my Synology.
I’m sitting in the office right now and can connect Roon on my Macbook via Tailscale to the Roon server at home. And here comes the peculiarity: On the iPhone, which is right next to the MacBook, I cannot connect Roon Remote to the Roon server (also via Tailscale). Roon ARC does not work either. It doesn’t matter whether I try to connect via the same WLAN as the Macbook or via mobile data.
Is the problem possibly on my iPhone 8 Plus, iOS 16.7.8?
But here too: I can use the iPhone with Plexamp to access the Synology, on which a Plex server is installed in addition to the Roon server and accesses the same music library, without any problems.