Issue with convolution filter and internet radio


I run build 339 and I have problems with MP3 based radio. Does this count, too? I use a convolusion filter with 75k taps and the radio stream won’t play at all. I have a different filter with
only 60k taps and in this case the radio stream plays. But this behavior hasn’t actually changed
with 339; 334 was the same.



Thanks for reaching out, @Michael_Thomas2!

I moved your post into it’s own thread since I think what you’re seeing here is a little different.

So we can better understand what you’re experiencing, may I ask that you please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

Does this behavior only occur with MP3 radio stations? Other stations work fine? What about other MP3 content?


Hi Dylan,

thanks for you reply. With FLAC radiostations I am having the same problem.
Convolusion filter off and the one with 60k taps works, the one with 75k does
not. I have tried this radio station:

This is the MP3 radio stream I tried in the first place:

With MP3 files stored on the computer where the Roon Core is running this
problem does not exist. The MP3 files played with all convolution filters. The MP3s I
tried was 192 kBit/s.

My Roon Core is running on a Windows 10 Laptop with Core i7 processor, 16 GByte of RAM and
512 GByte SSD, music files stored on a QNAP HS-210 NAS; sound output through Linn DS.
They all see each other through a wired LAN connection which is connected with the
Internet through a DSL router.

I control Room with a MacBook Pro and I just noticed that when choosing the MacBook Pro
as output the radio streams play with all convolution filters.

So it is a problem of radio streams + convolution filters + Linn DS.



Thanks for the additional information here, @Michael_Thomas2!

Would you mind sharing the filters that you’re using with me so we can do some further investigation here?


The first filter is the one causing problems. The second one is working.

I appreciate you sharing that will us, @Michael_Thomas2!

We’ll take a deeper look at this and be sure to update you on our findings.