“issue with database” after updating Roon

I’m having a very similar problem on my RoonServer on Win7. I opened Roon and it started updates on my local client and on the server. When the server finished and my client tried to reconnect, it had the “issue with database” error. I tried to reboot (no help) and then the instructions at https://help.roonlabs.com/portal/en/kb/articles/error-message-there-was-an-issue-loading-your-database#macOS__Windows__Linux_RoonServer

I reloaded the database, but it now said I had no albums, and an issue with storage location. I tried another reboot, and now I’m back to “an issue with database”.

Seems like I’ve lost everything. What should I do?

I decided to uninstall RoonServer from my server, and reinstall RoonServerInstaller64. After installation started the client on my laptop and tried to restore my oldest backup (instead of newest).

After relaunch, it prompted my for login. I tried that - now I have a client screen saying “issue with database”…


PS: Even worse, the clients don’t show any audio devices anywhere now.

I have the exact same problem. I’ve even uninstalled and removed roon from my PC and devices, downloaded roon again and reinstalled to no avail.

Same here. I’m not doing anything rash to try to fix this. Using a dedicated windows 10 machine as my server. Unless the update just corrupted my server, it may be a red herring. Multiple core reboots were no help. While updating my remote apps, screen says that my core is successfully updated to 880.

Just commenting here to say I’m having the same issue, on Mac Mini M1, after upgrading to the new version, and attempting db restore, and a full reinstall of roon too.

Same issue.

1 Like

Similar issues here running on MacOS Catalina on my older iMac.

I installed the latest update, and after it mentioned needing to update the database, so I let that run.

Everything seemed fine initially until I started searching, then it started showing the same database error message everyone else is seeing. I shut it down, relaunched, and it was fine until I started searching again (maybe it was more timing based and just happened to be when I was searching). Did this multiple times until I realized something wasn’t right with the database.

I tried resorting from a backup and that failed. I tried backing up, that failed. So now I uninstalled and reinstalled everything, and trying to restore my last backup but it’s crawling. Not sure if it’s gonna work once it’s done.

Seems like there’s some issues with the new update and the database migration. Hopefully this gets resolved quick and fixes our databases. Thankfully I have database backups to restore to, hope y’all do too! :slight_smile:

Update: I let the restore run overnight and it worked, but then as soon as I relaunched I just started getting the database error again. :frowning:

exact same issue here:
Windows 10 machine, roon core, I do several clean reinstallation and unable to load database and unable to show up audio devices with the latest update. The build version 850 (or 830 I dont remember the exact number) the build just before the latest update works fine, however roon downloads and installs latest build immediately, devs should do something, or they shuold try roon on all platforms before release any new update…

Similar issue here with ROCK. What should I do?
I have many playlists and tags.
My restore doesn’t success. :frowning:

Hi all, I wrote about this in more detail in the post below.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.