Issue with laptop running core connecting


(Bryce Lewis) #1

So here’s the situation. I had a full Luxul network (Epic 5 router, AMS-2616P managed switch, AMS1218P managed switch, XWC-1000 wireless controller and two XAP1510 WAPs) and my Roon was working fine. I’ve since moved and took the 2616P and one XAP1510 with me. The place I moved to has a Pakedge WR1 wireless router and a Netgear GS116NA switch. The configuration is as such: Pakedge WR1 router > Luxul AMS-2616P switch > Luxul XAP1510 WAP.

My laptop, attempting to run Roon core, is connected wirelessly to the XAP1510, as is my iPhone 7+. In this configuration, my phone shows my laptop as “Connecting” and “Connection Failed”. It never connects. From my laptop, when I attempt to send music to my Sonos Connect or AppleTV, it does not work. Now, if I hardwire my laptop to the Luxul switch, my phone shows the laptop as “Connected” but still will not stream music. I tested my laptop and phone connected directly to the Pakedge WR1’s WiFi signal, and everything worked absolutely fine. The same is to be said with my laptop and my phone on my network at work.

Nothing I can see in my switch or WAP would indicate it shouldn’t be working, granted there are a lot of settings in my switch that I have no idea what they do. As I mentioned earlier, Roon worked fine at my old residence with the exact hardware. Only change I made to the Luxul hardware was switching it from a 192.168.10.x IP address, to a 192.168.0.x IP address (to match with the Pakedge versus my Luxul router).

Can someone help me? I’m pulling out my hair here.

@steve @support


(Dylan Caudill) unlisted #3

(Dylan Caudill) #4

Hi @Bryce_Lewis,

Since things are working okay with the Core and remote connected directly to the primary router it definitely sounds like the difficulties are either stemming from the AMS Switch or the XAP WAP.

If you were to put things in the following configuration temporarily how do things work?

  • Remote connected to Pakedge WR1 router
  • Laptop Core connected via Ethernet to AMS switch

(Bryce Lewis) #5

Remote connected to WR1 router and Laptop Core connected via Ethernet to AMS switch works.

Remote connected to Luxul WAP and Laptop Core connected via Ethernet to AMS switch works.

Remote connected to either Luxul WAP or WR1 router and Laptop Core connected to Luxul WAP does NOT work.

Seems to be something with the Luxul WAP at this point?!

I’ve attached a photo of the Luxul WAP Settings. Client Isolation is disabled (not pictured).

Luxul%20WAP%20Settings|259x500


(Dylan Caudill) #6

Hi @Bryce_Lewis,

Thanks for the info here! Based on the test results above it definitely sounds like the Luxul WAP is causing some networking issues here.

As noted in our networking guide, we typically recommend against these kinds of networking devices as we’ve seen them be the cause of similar issues. Since this same device was working for you in without issue in a previous configuration it’s likely that this device can be configured to work properly with Roon, but it may take some advanced setup.

Unfortunately, the screenshot you shared doesn’t appear to be coming through on my end — Can you try resending the photo of the settings?


(Bryce Lewis) #7

Against what type of devices? WAPs?

I’ll try the photo again.


(Bryce Lewis) #8

I figured it out.

After I factory reset both my WAP and my switch and it STILL didn’t work, I turned to my laptop. For whatever reason, on my WiFi network, my laptop was set to “Public”. Which, as we all know, is the most locked down in terms of device visibility on the network. The second I switched it to “Private”, it registered as online (Ready) on my phone and I could stream music.

Easy peasy. Weird though why my laptop was set to Public for my home network that I’ve been using for the last three years with no issues.

Oh well, thanks for the help!


(steven silberman) #9

Bryce – Thanks for posting this solution.

Steve


(system) closed #10

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.