Issue with Moon Mind 2

I’ve got a Moon MiND 2 newly installed and I’m very impressed with the sound so far. Roon works perfectly with MiND 2 either streaming from my Roon Rock or Tidal or Qobuz. However when operating via the Moon MiND software I can access Tidal and Qobuz but not Roon Rock - it doesn’t appear as an option on the services available in MiND.
However when I’m playing tracks from Roon Rock via Roon and switch to the MiND software the album cover appears on the left of the screen and playing time etc is shown. This continues as tracks change.
I tried tagging the Music folder in Roon Rock as a Network Share and that didn’t make any difference - it still didn’t show up as being available.
One other bit of info that my be useful. Moon MiND shows my Terrastation on which I store Apple lossless files as available but when I select it only the small number of files that are MP3s are accessible.
I’m running Windows 10 and wired gigabit internet.
Any advice available would be much appreciated.

Hi @John_Butler,

To access the ROCK internal storage, you can use these instructions, and the music files would be stored in the Data/Storage/(FolderName) location.

Do note that this type of connection is via Samba and and it is dependent on the Moon Mind application supporting Samba connections over the network. I cannot say for sure if it does, so you would need to verify on your end.

Thanks Noris for getting back to me. I’ll check if the Moon Mind supports Samba and see how I get on.

1 Like

The MiND2 App uses a UPnP music server to access your local music library.

I have used Asset UPnP with my MiND2. Available at for a $29 OTP.

Thanks Michael. Does Asset UPnP music server result in the MiND 2 being able to access your local Roon Rock music library directly?

Yes it does, but you will have to point Asset to the proper location.

Thanks Michael. Yes, I pointed Asset to the proper location and it worked perfectly. However it sometimes disappears from the Mind Library list for no apparent reason. Rebooting the PC and the Mind unit sometimes restores Asset and sometimes it doesn’t. Sometimes it just appears next time I start it up. Presumable there is something conflicting somewhere! Any ideas appreciated.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.