Issue with Roon Arc connectivity despite UPnP and manual port forwarding efforts (ref#XGR0OG)

Network Setup

· My only router was provided by my ISP

ARC Status

· ARC is *Not Ready*

Roon Error Code

· “natpmp_autoconfig”: {“status”:“NotFound”}, “upnp_autoconfig”: {“status”:“NotFound”} }

Have you successfully located and enabled the UPnP or NAT-PMP settings in your router's web UI?

· I've turned UPnP/ NAT-PMP on and ARC won't connect

Select the Diagnostic Keyword or Text String

· Something else

Don't give up yet.

· I'm stuck. I'd like to create a post to ask Roon Community for help.

Describe the issue

Roon Arc Not Connected despite trying both UPnP and manual port forwarding. Error message the same in both scenarios:

{
"ipv4_connectivity": {"status":"NetworkError","status_code":504,"error":"error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined"},
"external_ip": {"actual_external_ip":"152.aaa.bbb.ccc","actual_external_ipv6":"null","router_external_ip":"null"},
"natpmp_autoconfig": {"status":"NotFound"},
"upnp_autoconfig": {"status":"NotFound"}
}

Describe your network setup

ISP Metronet
Network router is Eero 6e
Connected via wifi
Roon Server is Macbook Air 2015

@Rohit_Devnani, welcome to the Community. The diagnostics you’ve provided suggest that UPnP is not properly configured on your router.

Please first try the following steps:

  • Try to enable UPnP/NATPMP in the web administration interface for the router directly upstream from your RoonServer
  • Try to manually open the port in your router’s port forwarding configuration
  • Make sure the IP/Port matches the Port listed in Roon → Settings → ARC
  • Check for any VPNs or Firewalls that might be interfering
  • Check if your modem is in Bridge mode

If you continue to experience difficulties, please tag the support team and include the following information:

  1. Do you have any additional network hardware, like additional routers or managed switches?
  2. Is your Modem configured in Bridge Mode so that it operates only as a modem or do you have the ports forwarded on both?

Have you used these eero instructions for de-activating and activating UPnP and port forwarding:

Also, please make sure that you are using either UPnP or port forwarding rules, but not both. The error message you posted above indicates that UPnP is not active.