Issue with Roon Arc not Connecting to Roon Server App on PC (ref#DP7BAH)

What’s happening?

· Something else

How can we help?

· None of the above

Other options

· My Roon software won't start up

Describe the issue

I loaded Roon Arc on my android phone. it loads the icon screen but does nothing.
is this the correct version to connect to the Roon Server app on my pc?

Describe your network setup

Windows 10 PC. SonicWall 360W firewall

Is this at home or are you at work and your RoonServer at home.

One and the same my office is in the house. Currently my phone is on wifi from my sonic wall

Hmm, then I would assume the SonicWall is blocking something. If you look at your RoonServer from a PC and go to the ARC settings page, does it read “Ready”?

It doesn’t need to say Ready for working on the home wifi, though. Nevertheless, I’d also guess the Sonicwall is blocking access to the Roon Server on the LAN

Sorry i didn’t see that section. I see I need to map port 5500 testing now…

I am trying to setup a policy. the documentation says Roon uses either UPnP or NAT-PMP. I don’t see them on the list I attached the list…

To be sure: It‘s 55000 (or similar) and not 5500. And normally it is only necessary for access from the internet, because normally all ports are open on consumer LANs, anyway. I.e., ARC normally works on the LAN without this.

Though it’s possible that your Sonicwall blocks things on the LAN, too.

These are completely different things.

  • UPnP or NAT-PMP is a protocol on the LAN that allows automatic configuration of port forwarding rules for network traffic from the internet. I.e., devices on the LAN, like Roon, can tell the router to create a port forwarding rule for them.
  • You, however, seem to be manually configuring traffic protocols yourself. I’m not sure what it is you are configuring because your screenshot only contains the menu for the protocol choice.

But, if you are manually configuring a port forwarding rule, then the correct choice for Roon is TCP in this menu.

I’m not a expert at setting up firewall port mapping. Still working on it at least now i know the proper port protocol.
Thanks for your assistance.

Hello @john_morina ,

Can you please confirm the affected Android device’s model/manufacturer/system info? Have you tried to uninstall the ARC app and reinstall it, was the behavior the same even afterward? Is there any change in behavior if you manually install the app APK?

https://download.roonlabs.net/builds/RoonARC.apk

I was able to get Roon Server set to Ready for Roon ARC.

Manually downloaded the version from your link. It connected and it works. However, it only allows me to play music on my phone. When I am in the house, I need to be able to play music to my M1T streamer like I can do from Roon Server software.

This is the purpose of ARC. It only has output to the phone:

Install the “Roon Remote” app from the Google Play Store, not Roon ARC. This is the main app for Roon at home.

Thanks That worked. I guess i can use Roon Remote when at home. and use Roon Arc when not.

While this is true if the OP really wanted to, they could then send it via Bluetooth to audio gear in the home, not its true purpose but it does work.

In principle yes if the streamer accepts BT, though the M1T does not seem to. But even if it did it would be silly to use lossy BT when the M1T is Roon Ready, and end up with fewer app features as well with ARC. So I did not think to bring this up :slight_smile:

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.