Issue with Roon ARC on Samsung S24 Ultra intermittently failing to play Qobuz or Tidal music (ref#UIU4J7)

What’s happening?

· I'm having trouble with Roon ARC

What best describes your issue with ARC

· Other

Describe the issue

I posted about this issue about a week ago, it randomly went away overnight but then when I got to my car to use android auto, Roon ARC was not showing up in android auto, so I reinstalled it and the issue has returned.
https://community.roonlabs.com/t/troubleshooting-qobuz-playback-issue-on-roon-arc-s24-ultra-ref-kg6d2p/275486


The issue:
I have been running Roon ARC on my LG V60 for a good while now with no issue after the Last.fm bug was fixed. I decided to upgrade to a Samsung S24 Ultra with Verizon last week. Immediately I've been having issues.

Roon Remote and Roon ARC both play everything fine if I'm on Home wifi, but the second I take Roon ARC off of wifi and go on mobile data Roon ARC refuses to play Qobuz or Tidal music. It will play my personal library but it will not play anything from a streaming service. To be more precise, it will play a single song immediately after reinstalling ARC, no songs after that and then once in a while it will play a singular song after some buffering, there is zero consistency to it and its like a 99% failure rate. It will just infinitely buffer and then either just stop or say the connection isn't good. Anything within my own personal library plays fine. I've tried disconnecting and reconnecting both services, I tried using plexamp with Tidal and no issues. Qobuz through its own app works just fine. I also went and got the s24 ultra replaced by Verizon and got a brand new one, same exact issue, no change. So it's not the specific phone. Also tethering internet from the s24 ultra to one of my two LG phones will let those LG phones play all music perfectly fine, so it's not a server arc configuration problem or a connection problem. This is some weird issue between s24 ultra, roon arc and streaming services. I'm honestly perplexed, I'm a technological inclined person but I can't wrap my head around this issue, especially the fact that it worked perfectly fine for like 5 days out of the blue and then stopped working again after a reinstall of the app. I've also tried using older versions of the app, to no avail.

I'm giving it til my 30 day return window is about to end, in about 22 days, at that point I'm giving up and returning the phone and going back to my LG V60, as I have things I don't like about the new phone and not being able to listen to my music is the final straw.

Update: I’ve done some further testing. it seems that if i leave it alone for a few hours and then play a song, it will play the first song, and sometimes even a couple of songs after that if i DONT skip anything. the longer the song is, the higher the chances itl work. i can also prebuffer songs using wifi before going out, again if i dont plan on skipping any songs. this seems to be some buffer issue, like its getting a REALLY slow connection to qobuz through roon arc, but only on this phone as i mentioned before. I have resolved the other issue i didnt like about the new phone, so i would REALLY like to resolve this before my 30 days is up.

Any testing you want me to do, I’m more than happy to do.

Describe your network setup

Comcast Xfinity, Arris Modem, Netgear router. Verizon 5g mobile internet.

Hi @Lukas_Michalek,

Thank you for your post. We’ll happily extend your trial for the duration that you’ve been without ARC - please let me know and I’ll reach out to our accounts team on your behalf.

On your RoonServer machine, do you have any VMs or VPNs that RoonServer might occasionally use to connect? Diagnostics indicate ARC has lost session authentication, relegating you to cached images and audio within the app. A common culprit from this condition is that RoonServer has reached ARC through a separate (but functioning) network pathway, like a proxy mesh VPN.

No vpns or vms running the roonserver, it is running from unraid docker, straight connection, no vpn. Its running as host in the connection type. Proper ports are open. As i mentioned before, both of my older phones seem to be able to connect just fine and even running tethered using the s24u data as a connection for those phones. It seems to only be the s24 that has the problems connecting, and only when using mobile data.

Ive been running problem free about a year like this, nothing has changed server side. Only thing that changed from 2 weeks ago to now, is i got the s24u and stopped using the lg v60 as my primary phone.

As far as a trial, ive been subscribed and paying for about 1.5 years now. Only the last 2 weeks have been an issue.

Im unfortunately going on a trip today and wont be back for about 5 days, but if we cant find something to try til then, ill try migrating my roonserver to a windows machine to see if the issue persists. I still have access to the unraid docker remotely though. If going to a windows machine works, I would still like to find a solution, as my the unraid is my server which is always running and i dont leave my primary windows machine on all the time

So I’m back from my trip. I tested running a new fresh docker install on unraid, no change, i then tried running the server on windows 11. I disabled the firewall, put the router into DMZ, still no dice. I even tried resetting my router, only putting in the 1 port for roon arc, still nothing. mind you, during all of this roon and roon arc both say roon arc is accessible and it is on literally ANY other device.

I noticed when I was driving home it still wasnt working, but when i used the screen on android auto to pick something to play instead of the phone, it suddenly started working like nothing was wrong, it then allowed my device to work flawlessly even when disconnected from the car, but then after restarting the phone it started doing it again. This is 10000% something with roon arc and the s24ultra with mobile data, this can’t be a server configuration problem. This also isnt a network issue with my phone ISP because if i tether that internet to another device roon arc works just fine. But I’ve now had 2 different brand new s24ultras and they both had the exact same issue and as i mentioned, neither of my LG phones have this issue.

I tried setting arc as unrestriced in the battery permissions, i enabled “allow data usage while data saver is on”, as I mentioned ive tried installing older versions, everything.

I’m honestly not sure how to proceed, I definitely require further assistance, because I can’t fix this on my own and at least like 70% of my listening is done on ARC. My Qobuz app has been working flawlessly.

I have the week off, so I have plenty of time to do any form of testing you want me to do to try and diagnose this.

I was getting close to my 30 day return window and there were other issues I had with the phone so i just returned it, ill be getting an s23 ultra, which i tested roon arc on a friends s23 ultra and things ran just fine. My LG V60 is once again on the mobile plan and having zero issues with roon arc, it was truly just something with the s24 ultra.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.