Issue with roon arc server connection and network errors (ref#YA97NA)

What’s happening?

· I'm having trouble with Roon ARC

What best describes your issue with ARC

· Other

Describe the issue

roon arc is unable to connect with the server.
"ipv4_connectivity": {"status":"NetworkError","status_code":504,"error":"error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined"},
"external_ip": {"actual_external_ip":"62.aaa.bbb.ccc","actual_external_ipv6":"null","router_external_ip":"null"},
"natpmp_autoconfig": {"status":"NotFound"},
"upnp_autoconfig": {"status":"NotFound"}

Describe your network setup

homework network is working well.

You do not appear to have uPnP enabled on your router so the Roon Server can not automatically configure the ARC connection.

In order to get ARC to work you will have to do one of three things:

  • Enable uPnP on your router - often this will work - sometimes it does not.
  • Create a manual port forwarding rule to forward incomming TCP connections on port 55002 of your Router to your Roon Server on port 55002 at ip address 192.168.1.5.
  • Use a Tailscale VPN to avoid the need to configure port forwarding altogether.

The first two are covered in the Port forwarding articles in the Roon Help Center:

The last option, Using Tailscale, is also covered in a help centre article:

Note: If you solve the issue using Tailscale, then the ARC settings page that you have posted a screen shot of above, will continue to report “Not Ready” and will continue to supply the same diagnostic text. This does not matter because the whole point of using Tailscale is to provide ARC with Local Network access to the Roon Server - no matter how the mobile is connected and thus, port forwarding on the Router becomes immaterial.

2 Likes

Hi @rb0501,

Please let us know if the above steps helped remedy the issue. We’ll keep this post open for a few days in case you require further assistance.