Issue with Roon playback stopping and showing "waiting for server" message (ref#JUIE01)

What’s happening?

· Something else

How can we help?

· None of the above

Other options

· Other

Describe the issue

When using Roon, as opposed to using either Tidal or Qobuz on their own, my selection will start playing and then stop after a minute and gves me a message saying waiting for server. After that, it allows me to play again. This only happens on Roon. Both streaming services play fine on their own.

Describe your network setup

I use a wireless router, not sure of the manufacturer. I run Roon on my laptop as an endpoint through my Wimm Pro streamer.

Hi @jimmshffr,

Thank you for the post. The message you’ve described indicates that the RoonServer instance and the Roon Remote aren’t able to reach one another through the network. If you’re using one computer as a Remote and Server, then I’d verify that a firewall isn’t interfering (like Windows Defender).

If you test with an ethernet connection to the laptop, can you still reproduce this screen?

As far as i can tell my laptop is allowing Roon to get through. I will double-check that, though. Using an ethernet cable was going to be my next move. Ill post the results. Thank you!

My firewall is allowing Roon to get through but i still get the message about the server.


Hi @jimmshffr,

Were you able to get an ethernet connection setup with your Roon Server machine?

Yes but unfortunately without any luck. No improvement.

Hi @jimmshffr,

Thanks for the update! And what happens if you temporarily disable your windows 10 firewall? We’re not able to connect to your Roon Server to enable diagnostics at this time, so there could be a blockage or restriction from the machine’s firewall.

Here’s more info:

I’ll give that a try and see what happens. I’ll get back to you. Thanks!

1 Like

Well, everything got worse. I checked tge correct boxes on the firewall and also tried turning off Defender. Didnt help. Teied uninstalling to reinstall. It wont let me. Says Roon is still running when its not. It took a goid half hour to finally connect but where i could hear portions of songs before it gave me the server message im now only getting the server message. No song at all. Maybe its my laptop. Everybody else seems to be just fine using Roon. As for me i would rather be listening to music than getting frustrated over Roon.

I thought I had. I went into uninstall and uninstalled one of the two and that worked. But when i went into the other to uninstall that’s when i got the message about another program running.
![20240710_172901|375x500](upload://9tNdiFA52MeBInOjtez2T1mLUte.


jpeg)
I hope the picture from my screen was sent. When i tried to uninstall the roon it says please quit all instances iof roon before continuing. That is the only roon app left to uninstall.

Also when i do get roon up and running on that very rars ocassion before the message appears about the server then i don’t seem to be able to connect to my phone remote. On either of my 2 phones. Thank you for your help.
Update: after watching 2 movies i tried connecting again. It connected faster than it had been and played 2 1/2 songs before i got an error message. I tried again and now ive heard several songs without the message. I wish i knew what was going on. I still cant connect to either phone.
Ill put the laptop down and try again tomorrow. Maybe ill get lucky and it will play without the message appearing. Ill update you.


My screen when i open roon from the file location.
When i go to my uninstall screen it only ahows one instance of roon. Here it shows two…appliance and server?

You have to quit the Roon Server which is a separate program and not the same as the Roon control app. Like here:

I did not realize that. I will try that tomorrow and update. Thanks! ( I do believe that it was sitting in my tray while i was trying to uninstall.)

A post was split to a new topic: Roon reserved IP with NAS