Issue with Settings >> Audio >> devices

Core Machine (Operating system/System info/Roon build number)

iMac (Retina 5K 27 inch 2019

3GHz 6 core intel core i5

Memory 32Gb

Catalina 10.15.5

Hybrid Drive


MacBook Air
1.7GHz Dual core intel core i7
Memory 8Gb

Catalina 10.15.5


Also Docker Toolbox and Container running on above iMac - 8gb and the same 6 core i7 processor

Also VirtualBox and a VM running Debian 10.4 and Roon Core latest version

Synology DS216Play

Running DSM 6.2.3

4TB HDD Raid 1

Total tracks currently 12275

Roon 1.7 Build 555 with latest updates applied
Preferred install is with iMac running RoonServer and Roon as Control so that Roon is always running whether or not Roon control is running. Also use iPad and iPhone apps.
However have also tried installing just Roon as control, core and output and this makes no difference to the issue.

Lifetime licence

Also have a Qobuz Sublime+ account

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

BT SMart Hub 2
Netgear 24 port gigabyte switch
BT Whole Home Mesh and ethernet (NAS)
Have tried iMac both ethernet and wireless

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

System Output plus Auralic Aries and Auralic Altair G1.
iPhone and iPad
N.B. this issue applies whatever output device is used.

Description Of Issue
From time to time (maybe once a day or so) I can have issues with a device which was previously enabled showing as 'Enabling with a blank name field and it just gets stuck.
Entering a name seems to cause Roon Control to crash on whatever device you are using for control (I have had this on my iMac, Macbook, iPhone and iPad.). I think there maybe a connection between whether you are enabling a device on Control running on the device - i.e. enabling Audi on iPhone from the iPhone.
Usually but not always going back into the control app shows the device enabled. This doesn’t seem to be happening with RoonServer on Linux but if it does happen I will confirm as soon as I can.

1 Like

That should be build 571

I can also confirm this is happening on Roon Server on Linux.

I also found if stuck on enabling with the empty name box then it will appear as stuck on each control point for that controller - i.e. if you view Settings >> Audio on the iPhone and the iPad is showing ‘enabling’ then viewed on the iPad it also shows the iPad as enabling.

Trying it just now entering text into the iPad device stuck on enabling crashed the iPhone control app. Entering text on the iPad did not crash the control app on the iPad and reloading on the iPhone the iPad was enabled.

Hello @Marcus_Russell, thanks for your report! I ran this thread by our QA team and they asked if you could provide specific reproduction steps to get into this state. We’re happy to test this out but were unable to reproduce this on our end.

Hi @nuwriy

This issue is intermittent but I have managed to replicate it this morning.
For reference this is with Roon Server running on a Linux machine.

Loaded Roon on my iPad.
Went to Settings >> Audio
The iPad appeared as enabling but didn’t enable

So entered the text

Hit return and the app closed

On reopening the iPad was there but named differently as Marcus’s iPad (which is the correct original name)

Since doing this at 11:20 BST this has now happened again at 11:54 BST but it can be stable for quite a while.

Thanks @Marcus_Russell, I’m going to enable diagnostics for your account so we can get this info over to the team.

Similar/same thing happens to me when trying to choose to use my iPad as the output device from the Roon app on the self same iPad. More often than not I see the same thing mentioned here where it shows ‘Enabling’ with a blank name field. Entering a name seems to cause Roon Control to crash . When I reopen the app things seem ok again and I can successfully choose the iPad as output.

Just thought it might be helpful to know you’re not alone!

Thanks @gkoop - it sounds the same and it does help :slight_smile:

Hi @nuwriy

The issue has arisen again this evening.

This may be coincidence but I noted the following:

Load the app on iPhone
iPhone was immediately available as an end point
Leave the app playing on a different end point (i.e. not set to output to the iPhone)
Leave the iPhone to go to sleep
On awakening and going to the app (which is still loaded and which will display the last displayed end point with what ever is playing) then select that output as if to switch zones - the iPhone is not available
Go to Settings >> Audio
the iPhone shows as ‘Enabling…’
Enter a name
Hit return
Control App disappears/crashes
On reloading the Control app the iPhone is now available from the current playing item when you select to switch zones
Exactly the same thing happens with an iPad
At no point did I actually select the iPhone for output (or in the case of the iPad the iPad)

Hope this helps

Hello @Marcus_Russell, while researching this thread I found the following directions from another support member that might be helpful here. Please give this a try!

Hi @nuwriy

The issue is rather different as far as I can understand and this relates to a containerised Roon Server environment - I am running full Debian Linux and it doesn’t use the ‘deep freeze’ concept as far as I know.

I have also seen this same issue with Roon Server on Mac OS on both my iMac and MacBook Air so I don’t think this is the cause of my issue.

Thanks anyway

Hello @Marcus_Russell, thanks for checking that. Another item we wanted to try was your other mac as the core. I know you had mentioned it in the first post, have you tested it to see if the issue is present there too?

Hi @nuwriy
Yes I have and yes it is present there too

Hello @Marcus_Russell, could you please reproduce this issue one more time with the iPhone and iMac one more time and reply here with a timestamp when you do? I’d like to enable diagnostics for your account and get a report to our QA team for further analysis. Thanks!

Hi @nuwriy

Will do - it will be next week as I am away for a few days

Hi @nuwriy

I have now replicated this but it is still difficult to repeat to order.

iPhone 7s running iOS 13.6
Roon app is always in Dock

iPhone running and Roon Control already running on iPhone
On iPhone tap Roon app in dock - appears to crash
Go to Switch Zone - no iPhone end point showing
Go to settings >> Audio
iPhone showing as previously stated ‘enabling’ - wait a few seconds nothing happens
Enter some text to ‘name’ the end point
App crashes
On reloading app the iPhone now shows in switch zone and settings as enabled and all works until the next time
All times are BST
Checking the RoonServer log this started at 08/17 06:48:37 with connection working at around 06:52

I then closed the iPhone at around 08/17 06:53:47

Hi @nuwriy

I have just noticed this approach

load Roon control on my iPad (technically it’s in standby mode I believe)
go to zones from the track currently playing
If iPad is not showing as a zone then force close the app
Reload Roon control
And then in zones the iPad is now available

Hi @nuwriy

In my last but one post I stated:

On iPhone tap Roon app in dock - appears to crash

However I think it maybe is loosing focus - i.e. it disappears but if I check for what apps are running it still shows

Hello @Marcus_Russell and thanks for the detailed steps! I’m going to get this information over to our team now.

9 posts were split to a new topic: Blank device name

Hello @Marcus_Russell, my apologies for the delayed response. Our team is still investigating the issue and would like to pull a fresh set of diagnostics. Could you please reproduce the issue one more time and reply here with a timestamp of when you do?

Afterward, please use the directions found here and send us over a set of logs using a shared Dropbox link.