Issue with skipped files on import

Just setup a trial of Roon (Roon 1.3 build 196), I have Core running on OSX 10.11.6 and my music is on a NAS. [NAS is a synology with the disk volume formatted to ext4]

I was able to setup Roon to read from the NAS and the import chugged away. I noticed on the skipped files section that there were a number of skipped files, e.g.

All the files were originally created by iTunes on the Mac and rsync’d to the NAS. All the skipped files have non-ascii characters in their names. I saw in the FAQ about not using special chars, but it lists a small number of specific chars, it makes no mention of non-ascii chars.

Does Roon only support filenames/paths with ascii chars, is this some problem related perhaps to the rsync to the NAS and file system type differences ?

FWIW, My Bluesound Node2 had no issues scanning the same NAS, it imported those files fine.

Thanks, other than this minor issue, have been super impressed so far.

As an experiment can you try saving the files elsewhere then renaming the files in the Roon folders? I usually only have problems with special characters when changing file systems.

I tried copying the files using Finder instead of rsync, that didn’t help. I also setup RoonServer on a linux VM [as my long term plan is run RoonServer on linux on a NUC] and that had no problems reading theses files from the NAS. Not sure what’s going on perhaps Roon on the Mac is picking up a different text encoding setting that what everything else is using.

I would try changing the file name on one of them as a test to see if that is the issue.

After various experiments here what i found

a) Mac core: file works fine from local disk
b) Mac core: file is reported with I/O from NAS
c) Mac core: rename file [to pure ascii chars], works fine from NAS
d) Linux core: file works fine from NAS

Mac core problem is the same regardless if the file is copied to the NAS by rsync, or by finder.

Seems like some issue with UTF8 filenames on remote drives from Mac core.

Not going to be a blocking issue for me, will have my real linux NUC core up and running next week.

Thanks all

I’ll look into this a little sometime next week, but I suspect there isn’t much we can do. It feels to me like a problem in the Mac SMB system, which we obviously don’t control.

Thanks for doing the work to produce a really clear description of the problem, it makes my job a lot easier and I really appreciate it.