Issue with skipping tracks with large library

I exactly have the same Problem with a 400k library. Reboot everyday, after eboot all works perfect, till I skip a track, then the horror is starting. No Memory, no IO Issue and CPU is idling on the server. i tried with 4 different server, on all the exact same issue

Just out of curiosity, how many tracks are from streaming services, and how many are local stored files?

It is half local and half tidal

And if you log out from Tidal, is there a small improvement or rather a hugh one (taken into account you only have half a library than)

Not really, as long i do not skip songs it works fine. Without tidal, i would say it works a bit longer after e restart. As soon there is a library update and I skip exatly in this time the problem does start and goes till a reboot or restart roon processes not away

Hi @Marco_Kohler,

Can you please provide some more information regarding this issue?

  1. What kind of Core/OS are you using/did you try?

  2. What are your audio endpoints?

  3. Does this same behavior occur on multiple endpoints (including on “System Output” of the Core)?

Hi Noris

  1. ROCK, Windows 10, Windows 2019 and currently Windows 2019 Core
  2. Devialet 440 Pro / Ropiee on Raspy 4
  3. problem is on both endpoints, devialet is abit more tricky then the rb

Ich can tell you when the problem occurs next time, you might enable then debug logs


Hi @Marco_Kohler,

Sure, please let me know the exact local time + date + track when you next experience this behavior and specify which Core you were using.

For the Devialet zone, we are aware of an issue surrounding it on Gigabit switches, but the Ropieee behavior would be more useful in debugging this issue.

If you can please let me know the timestamps for Ropiee or for “System Output” that would help the most.

Does this behavior happen for both TIDAL and local library tracks, or just one and not the other?

Now the problem exist, 15:33 CEST, Skipping Song:
Deodato, Carnaval Triste ==> Frank Sinatra, Angel Eyes took over 20 seconds
Skippping again to Will Smith, Freakin it, took around 5 seconds

No all songs are having a long time till I reboot. As long it is running, no problem.

I do not reboot and look if it goes more worse and you might enable debug logs

And right now, totally error, only spinner, tried for several minutes to load This 'Ole Heart of Mine - Randy Crawford


From around 18:40 to now (19:15) no way to play a file, local storage nor tidal

Hi @Marco_Kohler,

Thank you for sending that log file over. I looked though it and it looked like the buffer was filled but for some reason the playback didn’t start. It also looks like there’s quite a bit of background library activity going on, do you by any chance see the “activity spinner” performing any functions?


Does this behavior also occur on the “System Output” zone (as to eliminate the endpoints from the equation?

Hi Noris
No, the spinner on top was not active, only at the bottom of the playback, the bar ran from left to right and back.
I had the same on both my endpoints, (Devialet RAAT and Ropiee)

Hi @Marco_Kohler,

Thanks for confirming that the spinner was not active. Can you let me know if the behavior also occurs on “System Output” (the Core’s internal speakers)? This will help eliminate the endpoints/their network connection as being a source of this behavior.

Hi @noris
I have no audio output on the affected device, I’ll try to connect the devialet through usb, but that need some time to test.

1 Like

Hi @noris
I just have the problem again, no way to play anything, also on System Output, nothing is going anymore. I moved my core to ROCK and added everything from scratch.

Hi @Marco_Kohler,

I assume that this issue went away for some time? What changed here, just the Core? How large is the current library after rebuilding ROCK?

If you set the current database aside and import less than 100k tracks, is the system stable? You can set the current library aside by:

  • Create a Backup of your current database
  • Stop RoonServer from running in ROCK’s WebUI
  • Navigate to your Roon’s Database Location
  • Find the folder that says “RoonServer”
  • Rename the “RoonServer” folder to “RoonServer_old”
  • Restart the RoonServer in the WebUI to generate a new Roon database folder
  • Verify is a library of 100k tracks or less exhibits this issue

This way we can determine if the large library size is a cause or if the issue lies elsewhere.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.