Issue with Tidal and Roon created playlists intermittently stopping playback (ref#FQBLSN)

What’s happening?

· Something else

How can we help?

· None of the above

Other options

· Other

Describe the issue

I have both Tidal created and Roon created playlists. Playlists at various times stop working. I can select individual songs from a playlist but the "Play" button does not work. All playlists consist of albums from Tidal. I have no playlists for local files. Apparently, adding and then removing a local file will fix the issue, but it eventually returns. Rebooting the ROCK NUC does not fix the issue. According to Roon I am running the latest version across the board. When this issue occurs, ARC is able to play any playlist. This does not always impact all playlists at the same time. It can be individual playlists or all playlists.

Describe your network setup

ROCK on NUC, Windows PC running Roon Remote and ISP router wired to the same switch.

Hi @Gideon_Kane,

Thanks for writing in! Could you please reproduce the issue and share the specific date, time, and name of playlist/track you have the issue with?

Thanks!

Benjamin -
I cannot reproduce the issue, or at least I am unaware what I might be doing that causes the issue.

I fixed most of my playlists by adding/removing a local file from each, but currently two playlists are showing the issue;
Tidal - Decalist
Tidal - New Releases

This has happened sporadically in the past, but in this instance, I noticed one of my playlists was experiencing the issue, so I rebooted the ROCK NUC. Once the Roon remote was able to reconnect all playlists were in the state where they couldn’t be enabled with the play button.

Let me know if you need more information.

Hi @Gideon_Kane,

Thanks for the update! As a next step, could you try removing your Tidal cache? Steps to follow below:

  • Stop Roon Server from running in the Web UI
  • Find and open your RoonServer database
  • Navigate to RoonServer/Cache
  • Move the contents of the /Cache folder elsewhere, like your desktop
  • Try restarting Roon Server via the WebUI and verify if the issue still occurs

@benjamin
Just to be clear, you want me to remove everything in the Cache directory?

cache_directory

Hi @Gideon_Kane,

Thank is correct! Alternatively, you can remove only the Tidal folders considering your issue is specific to Tidal in this case. Either option will allow for the same result. :+1:

Cache folder has been cleared and Server started.

Now I see a different set of playlists unable to use the “Play now” button.

Seems to impact random playlists each time the Server is restarted.