Issue with USB audio XCore 2.0 [Solved]

Hello @support,
I’m having an issue with USB audio (Xcore USB Audio 2.0, DAC Gustard AH20), the playback lasts for 3 seconds then it stops suddenly giving me an error (An audio file is loading slowly, this may indicate a performance or hardware problem). Same happens while I’m streaming Tidal.
I’m not having the same problem while using the RaspberryPi via Ethernet nor if I’m using the USB DAC through the windows mixer. Also I like to mention that on my previous laptop (an old i5 2nd gen) the issue never incurred.
My current setup is a new Dell inspiron 7000 with I7 8th gen, Roon version 1.3 64bit, music stored on USB drive, roughly 45.000 tracks.

Thank you

Luciano

I got the same error when using Windows USB Audio 2.0 drivers, but when I use the drivers for the DAC it worked. I don’t have the same DAC as you though, but might be a similar issue.

1 Like

Hi @Luciano_Saldi ----- Thank you for the report and sharing your feedback with, both are very appreciated!

Moving forward, to help us better evaluate this behavior you are experiencing with the Xcore USB Audio 2.0 + Gustard AH20 DAC, may I very kindly ask you to please provide me with the following:

  • Please verify if you make the same observations (i.e “An audio file is loading slowly, this may indicate a performance or hardware problem”) when playing back content that is on the internal storage of the Dell inspiron 7000.

  • In your report you mentioned that the same is happening when you’re streaming TIDAL content and my assumption is that is while you are using Roon (with TIDAL). Please verify. Furthermore, do you have any issues when making use of the mentioned audio zone outside of Roon? Say from the TIDAL application?

  • While I am not completely familiar with the Xcore USB Audio 2.0 and it’s capabilities, can you please verify that this is the device that you are making use of, and if you have tried removing it from the chain of communication (temporarily of course) to see how things hold up?

-Eric

Thanks @Magnus I’ll definetly try to install the dedicated driver to see if it works out!

Hi @Eric

Xcore USB Audio 2.0 is just the Gustard A20H itself, it uses the Xmos U8 usb receiver.

Tried the internal storage of the Dell (a 512GB PCIe NVMe M.2 Solid State Drive) and I get the same behaviour.

Using Tidal through Roon i get this error: “TIDAL: A networking or connectivity problem is interfering with TIDAL playback”

Tidal app is just working fine.

At this point, look also at what Magnus said it might be somthing related to some driver incompatibility.
I’ll also try to install the dedicated driver to see if I can sort it.

thank you!

Microsoft’s new “generic” USB Audio 2.0 driver has a bug that breaks RAAT’s clock management. Simpler apps (like TIDAL) don’t rely as heavily on drivers managing clocking information correctly, so some of them might work.

We recommend using the driver from the device manufacturer until Microsoft gets around to fixing it.

I’ll install the manufacturer driver then :slight_smile:
Thank you very much!!

The manufacturer driver solves the issue but I can’t find a way to permanently disable the driver signature in Windows 10.

I set the event driven mode off (with windows driver) and this eventually solved the problem.

Thanks for you help!!

This topic was automatically closed after 22 hours. New replies are no longer allowed.