Issues after 1.7 update

I followed the steps outlined above and get exactly the result Martijn did unfortunately.

My Roon core is running on a dedicated Win10 x64 Machine with the latest updates from Microsoft

Hi @B_Clarke,

I have split your post into it’s own thread so I can better assist.

Can you please let me know what you’re seeing in Roon? Are you presented with any error messages?

Can you send me a copy of your Roon logs via Dropbox / Google Drive by using these instructions?

Thanks, yes, I had the exact same msg as Martijn, after I reinstalled Roon, loaded a back up database, successfully, but then after it said it had to update the database for the new version I got the same screen as him, saying problem loading the database, go to the forum.

If I close Roon and restart it, it goes straight to that same error message each time–cannot load database.

I will endeavour to get you the logs!

1 Like

2 posts were split to a new topic: Issue Loading - Database Windows 10

Hi @B_Clarke,

Thanks for sending those log files over. I am seeing some issues in them so I suggest we proceed as follows:

  • Exit out of Roon
  • Navigate to your Roon’s Database Location
  • Find the folder that says “Roon”
  • Rename the “Roon” folder to “Roon_old”
  • Restart/Reinstall the Roon App to generate a new Roon folder
  • Restore from backup once more

Can you please give those steps a try and let me know if it changes anything?

Hi Noris,
I already tried that step yesterday, as I saw it suggested in the support forum. Same result unfortunately.

A post was split to a new topic: Unable to update Euphony Core

Oh, and sorry, I forgot to add many of the details:

Details on your Core machine (OS, Hardware specs)
Win10 x64 v1903
(Dedicated to Roon)

Networking details (especially what hardware you’re using, how everything is connected, and anything notable about how it’s all configured)
Cat6 from core to TPLink c5400x (where library is tethered via USB)

Audio devices in use
Chromecast audio x6, some wifi, some powerline networked

Library details (where your music is stored, whether you’re using a streaming service, how many tracks are in your library)
Ext USB hosted on router, 40k tracks plus Tidal


Hi @B_Clarke,

Thank you again for your patience while our technical team has been looking into this issue for you.

I spoke with our team today regarding their evaluation of the logs from your install. Sometimes, errors like the one you saw can be spurious, but unfortunately in this case they are seeing signs of low level corruption in your database.

This type of error is extremely rare for us and not one that we see often. Our database infrastructure is designed specifically to prevent this type of corruption, and we don’t take this class of issue lightly.

We’ve traced a few reports like this in the past to hard drive integrity issues but generally speaking, this means that Roon is reading information from your hard drive that is different from what was originally written, and the database is now unable to load properly.

What’s Next?

If you’ve been making regular backups, my advice would be to install Roon fresh on your Core machine, and roll back to one of your older backups. If the database loads properly, your edits, playlists, tags, etc should be intact, and we can confirm everything is performing properly once it’s been restored.

If you do not have any older backups, unfortunately you will need to start with a fresh database.

Again, this class of issue is extremely rare for us and you have our apologies for the trouble here.

Thanks for trying :slight_smile:
I tried two older backups, then bit the bullet. So I lost my playlists and history and internet radio stations, but at least I have music again. Thanks

Hi @B_Clarke,

Sorry to hear the older backups didn’t work as well :frowning: , in this case unfortunately starting from the fresh database is indeed the best way forward. Apologies for this issue and I hope you enjoy the new build and updated features!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.