Issues getting WiFi working - internal and dongle

Hi, I’m having trouble getting WiFi working. Using a Pi4 and Allo board. Wired is working fine.

When I go to the network settings tab in the web UI, with no WiFi dongle connected, the scan of nearby networks succeeds, I can pick my WiFi network name, enter the password and save and reboot. But it doesn’t actually connect to my WiFi network. Both before and after picking the network and saving the password, “Active Interface” says “external”. Shouldn’t that be “internal” if I’m using the built-in WiFi?

So, not trusting the internal WiFi, I got a USB dongle. A Linksys WUSB6300 which uses the Realtek RTL8812AU chipset, that sounds like it is supported. I plugged this in and it doesn’t light up. I plugged it into my MacBook and it doesn’t light up either, so not sure if it should light up just to show it’s powered. Either way, I don’t see any change in the settings web UI. It still acts just as before when it was using internal WiFi and I can’t tell if it’s even seeing the dongle. Still finds the network and says it’s using the external interface but I get no IP address, and it doesn’t seem to be connecting.

Not sure what to try next. I submitted a feedback log in case it’s possible to take a look and see what might be going on. 0f45cd9563017935

Any advice?

Thanks in advance!

The RPi4 internal WIFI works great. You just go into the RoPieee or RoPieeeXL setup and activate WIFI and put in your network and password. Save and reboot. Disconnect ethernet.

Unfortunately, I’ve tried that and I’m certain that password is correct. I’ve set it and rebooted several times. Tried with and without the ethernet connected. I’ve not seen it show up on my network and the “Active interface” is always saying “external”, which seems strange.

Does it look like this?

Here’s what I have now. Thanks!

I’ve never seen my Active Interface say internal

Maybe get rid of the dongle and reflash RoPieee micro SD card.

I’ve tried that too. I’ll give it one more try. Maybe review of the log will shed some light. Thanks for the help!

1 Like

Maybe your ssid or password got some weird characters?

Nobody is going to do anything with your ssid, hide it for what? :rofl:

No weird characters. In ssid or password. All letters in both cases.

Send a feedback to Harry here from the advanced menu tab

Your installation did not run properly, there was no internet connection.
Keep in mind that RoPieee requires internet during installation. Please reflash and try again.

Strange. I’m pretty sure my internet was fine on the initial install. I’ve tried 3 times now and this last one I’m certain it was connected to ethernet and internet was working.

I’ve just sent you a new log (fe7a7608d132cd01) from that latest reflash. On this reflash I’m attempting to use the internal WiFi on the Pi4 again and it’s still acting as described above.

It’s working great wired at the moment. Super cool product. Just can’t get wired to where I need this thing to be normally. Thanks!

So you downloaded the latest image?

I downloaded the image yesterday, so it was the latest as of yesterday. File is 20200724-ropieeexl-ose_rpi234-stable.bin

Ok. You need to reflash. Also, make sure that NTP is not blocked (by your ISP for example), because it looks like it’s failing to synchronize time which is essential for RoPieee.

If you send me feedback directly after the reflash I can have another look.

I looked into this and it does appear that requests to NTP are failing when I try this from Mac command line too. SNTP is working. I sent a question to my ISP but expect there’s nothing they’re going to do for me.

Harry, do you know what NTP server is being queried? Is there any way I can change this server address, in the case I’m able to set up a local NTP server to work around the ISP issue?


No you can’t change it. It just uses some servers from the NTP pool ( This should really not being blocked by your ISP. Maybe it’s something in your router?

Ok, it sounds like this port 123 blocking is fairly common and I anticipate that my ISP will not be making any changes to fix this. Doesn’t appear to be at the router level.

Will this failure result in fundamental initial install failures (that maybe are causing my wifi issue)?

I’ve got it working, seemingly without other issues, on a wired connection now.