Issues running Roon off of remote devices

Hi crew. Two remoting issues.

First, I have a Lenovo TAB 2 A-10-70F tablet running Android 5.0.1, 4 core 1.7 GHz, 2GB RAM. Wifi is on same network as my separate i7 computer running RoonServer with AO in minimal core mode. Roon never gets past “waiting for remote core” for the remote connection. I can access Roon core on the same tablet by running Splashtop and remoting into another PC at home, but I’d really like Roon to run natively on the tablet.

On my iPhone 7+, Roon runs fine, but if I switch apps on the phone, Roon goes to sleep and then I have to wait for it to find the core again to use the app. Is there a way to keep the app operating while open, rather than just when I am on the Roon screen?

Assuming I can get the Lenovo tablet to work, I will also want the app to stay running on it as well while open, regardless of what screen is up.

Can you folks help out on these matters? Thanks. JCR

Turn off any and all firewalls on the core machine, and possibly the router if it has that option. Even though you might have enabled roon in your firewall settings this is one of the most common can’t connect to core issues.

Audiophile Optimizer turns off the firewall. This is only an issue with the Lenovo android tablet. My iPhone connects to the core just fine on the same wireless network.

Further thoughts, and what about keeping it running and not going to sleep – both on iPhone and tablet? Thanks. JCR

Hi @Jeffrey_Robbins ---- Thank you for the report and the feedback! Both are appreciated!

In regard to the the behavior with the iPhone application, one of the reasons iOS is so good with battery life is that it aggressively puts apps in the background to sleep – one of the trade offs of that is when you “wake up” Roon, it has to reconnect. It should, however, only take a second or two. How long does the device take to re-discover your core machine?

Lastly, have you tried reinstalling the remote application on the Lenovo tablet during your troubleshooting of this behavior? If so was the experience any different or was it the same? Furthermore, can you please provide me the details of your network configuration/topology? I would like to have a clear understanding of how your devices are communicating and what networking tools you are using to make those connections possible.


Hi Eric. Thanks for jumping in.

My iPhone rediscovery is typically 15-30 seconds, which is why it feels like an eternity. Would love to shorten that to a second or two.

I have reinstalled the Roon app on the Lenovo tablet a couple of times, without any different effect. Ah, my network. OK, here we go:

My main wireless router is an ASUS RT-AC87U. The network map shows I have 30 clients currently attached. Specific to the issues here, my router is direct connected via ethernet to my Roon core, which is running on an i7 CAPS Zuma server built by Small Green Computer, which I have configured to run Audiophile Optimizer’s latest version in minimal core mode, and to my Synology 1813+ NAS, which stores my music library. I also have JRiver MC22 running on the server at the same time, which I use, remotely via JRemote, to access my music library on my iPhone 7+ out of home.

The router is also ethernet attached to a Netgear GS116Ev2 16-port gigabit ProSAFE Plus switch. The switch is configured with no management – for example, IGMP Snooping and Loop Detection are disabled, The switch is ethernet connected to a SONOS Connect box, an Oppo BDP-95 bluray player, a Marantz AV7005 preamp/processor, an Apple TV (latest version), a Small Green Computer sonicTransporter (to Roon-ize my Bel Canto renderer and DAC), a Mitsubishi television and another PC.

I have aftermarket hi-gain antennas installed on the wireless router so as to have a strong wifi signal. The router is located in the lower level of our large home and I use a series of repeaters to get the signal to the main and second levels of the home. Those are separate challenges, but I don’t believe they impact the Lenovo tablet issue here.

When I am using the Lenovo tablet, I am sitting not more than 12 feet away from the main wireless router and I am connected to its 2.4GHz wireless network. Although I can’t get the Roon app natively to run, I can connect to Splashtop, which in turn allows me to link to the additional PC in the same room noted above, which is also running Roon. While Splashtop access certainly works, there are limitations that would make running the Roon app natively on the Lenovo an advantage.

All firmware on the router, switch, etc. are the latest. Connections otherwise throughout the home are all set up as 802.11ac wireless. In total, I have 5 Roon endpoints running on Raspberry Pi3s with DietPi and five different DACs, the sonicTransporter to enable Roon for the Bel Canto products and five SONOS Connect boxes.

In short, if my complex setup can run Roon, anyone can!

Let me know if you need any further detail to offer up some suggestions here for both issues. Thanks. JCR

Are you loading Roon via the Google Play Store or running the apk downloaded from Roon.

Google Play store.

Hi @Jeffrey_Robbins ----- Thank you for following up and taking the time to answer my questions. The first thing that immediately jumps out at me in your network description is this:

“I use a series of repeaters to get the signal to the main and second levels of the home. Those are separate challenges, but I don’t believe they impact the Lenovo tablet issue here.”

Our CTO wrote up a very detailed and informative post about users potentially running into Wifi related issues. He mentions the following in his post:

"WiFi “range extenders” or “repeaters”. These have too many tradeoffs to be considered an actual improvement. These never worked well because they were too “dumb”. Mesh technology (where all of the base stations are coordinating with each other out of band of the WiFi signal) work much, much better.

Moving forward, while I am unable to debug your entire network, I can try to point you in the right direction. The most efficent approach I have found when a user has a complex network configuration is the “trial and error” method. Removing as much complexity from the chain of communication as possible and then adding the links back in to see where the issues occurs. I can speak from my own personal experience that when I have come across a problem like yours in my home (fairly spread out, multiple zones on multiple floors), this has always been the most reliable approach.

Being as my main “audio rig” is in our living room next to our internet access point, my troubleshooting always starts with the following:

Router - > Ethernet connection - > Core Machine + One remote.

Once I confirm this very minimal setup functions well and is stable, I add something else to the chain and then confirm that things are still in good health, and move on. While this may seem tedious, it is the best way to isolate any issues across a wide spread network configuration.

Lastly, can you provide me the specs of the machine hosting your roon core and the size of your library based on track count?


1 Like