Issues seeing KEF LS50W (power off and on KEF's resolved)

@danny – i’m apparently way behind on this issue (been dealing with big parent health issues a good portion of this year). i have a pair of kef ls50w speakers which work just fine on a nuc running roon core. i need to move the core to another machine, but on that machine it does not even recognize the ls50w under settings > audio.

am i to assume that the kef ls50w are not certified and since i didn’t get my notice in to you in time, that i’m pretty much SOL for getting the ls50w to work on my new core machine?

The ls50w have never been Roon Ready they are unaffected by any of this. They are Roon tested as they use Kefs own streaming protocol not RAAT and are not part of this change to certification… If they are not showing up then it’s down to changing your core setup not about being uncertified which they are not. Look at potential network issues such as firewall on new pc.

if that the situation, that’s very strange. it’s as simple as plugging in both cores to the network and seeing that they’re visible in one core and not visible in the other. nothing else is changed. (of course you have to go through the de-authorizing bit, but that’s it)

What is you running core on? Mac, Windows, Linux?

windows. i’ll restart everything and see what happens. thanks for the input.

Check firewall as well. Updates to windows can mess around with the settings. If you get no where with restarting try turning of its firewall and see if it helps and ensure both roon.exe and RAATServer are both exceptions.

I have the same setup, a pair LS50W mk1s (connected to my router via wired Ethernet) and Roon Core on NUC running Windows 10 also cabled to the router network switch. Sometimes my NUC, after working perfectly for weeks or months, simply will not see my LS50W one day when I bring the speakers out of standby and try to play music. I have found that restarting the Roon Core or even rebooting the NUC completely does not help. What gets the Roon Core to see my LS50Ws again is to power-cycle the speakers themselves by switching them on and off at the mains socket (I’m in the U.K. so all our mains sockets have switches, if you don’t then physically unplug the speakers from the wall socket and plug them back in again). It might not work for you but for me it’s always done the trick so worth a try.

@Julian - Rebooted everything… That seems to have done the trick - can see the ls50w now. I’ll keep my fingers crossed. Thanks!

1 Like

Brilliant. Really glad to hear that it worked. Keep an eye on things though because if you continue to travel the same path as me you might see them dropping out again occasionally. For me it is only maybe once every couple of months so a shame and enough to be a minor irritation but not often enough to be a major annoyance.

If it does happen again to you then I do suggest just power cycling the speakers first. Initially, before I fully understood how the problem was behaving in my setup, my steps to resolution were to restart the Roon Core process on my PC then if that didn’t work to reboot the whole PC and then finally if Roon still couldn’t see the speakers power cycle the speakers themselves. Restarting my PC is a far more disruptive process in my setup than power-cycling my speakers, even restarting the Roon process is a bit more bother because I need to go to another room, so now the very first thing I do is to power-cycle the speakers and that is usually the only step I need to take to get them seen again by the Roon Core which is obviously far quicker and more convenient and doesn’t involve disrupting my PC (which I also use as my main desktop PC).

1 Like

Unfortunately, the problem has returned. Currently, rebooting doesn’t solve the problem . . .

Hey Jim,

I have a pair of first gen LS50W at the office (would normally have them at home, but I’ve moved house this week, so dropped them there).

I’ll have a look if I can replicate when I’m in this coming week.

1 Like

@Ben_Hagens – would certainly appreciate it. just added an rpi4 right next to ls50w and it is recognized and works great wirelessly (but shouldn’t be necessary). it’s strange that the ls50w aren’t being seen by roon.

Same here, NUC with windows 10 and Kef LS50 W. Allmost every day Roon loses control and I have to reboot the KEF’s by powering them off … really dont know what causes this.

@Cantodea @jcn3 Hi guys. I’ve finally had a chance to give mine a try, haven’t been able to replicate, tried on a couple of networks too. Had a quick chat with customer service.

I’m assuming you are both up to the latest firmware? Last one released was Nov-2019. If not, first port of call is getting that firmware updated.

If you have, and/or have now done and still seeing the issue - open up the KEF Control app, turn on the LS50W, make sure the speaker is ‘connected’ in the app and then replicate the issue in Roon. Don’t power cycle LS50W until the next steps are complete.

Once replicated, pop into the settings section of KEF Control - at the bottom you’ll see ‘Send Logs and Feedback.’ Your email browser will pop up, and you’ll see an email already populated with a bunch of info, and the speaker logs will be attached (Cycling power will reset these logs, hence the previous mention of not power cycling). If you could write in a bit of description of what you are observing (does it happen on all music sources i.e. locally stored music, Tidal etc, is there an error message anywhere - anything you can think of) that would be really useful. Be as descriptive as possible (maybe not to Tolkien levels of 'talking about a tree for 7 pages though…). This will send a whole bunch of info directly to the dev team, who are much, MUCH better equipped and knowledgable at looking at code etc than I ever will be.

ben – thanks so much for following up. i’ll send the logs as you requested.

here’s the situation:

  • pic of settings > audio with ls50w on and the input set to wifi (note that dlna/upnp streaming does work)
  • pic when connecting an rpi4 connected via usb (note that the rpi4 is right next to the speakers and connected via wifi running ropieee)

Installed Roon Rock on my NUC earlier this week, replacing Windows 10. Since then no problems or issues… Roon doesn’t lose connection anymore… So lets cross fingers…

Sometimes my LS50W are not seen in Roon (I use wi-fi input). When this happens, all I have to do is cycle through inputs on the Kefs, then, when I switch back to Wi-fi, they pop up.

Same issue here, LS50W have disappeared from Roon. Performed all the steps and confirmed that Spotify can still see the Kefs. Will send logs, anyone found the cause? Cheers!