Issues when playing back local content from NAS

Hi @support,

I’m sending this on behalf of my bosses account. We current having an issue when playing back from local content which is stored on a NAS.

The setup is as follows:

(Server) Roon Core version 1.5 build 323 stable 64bit running on a core i7 desktop with 16Gb memory connected to gigabit network. (Wired / Windows 7 Pro)

(Client) Roon version 1.5 build 323 stable 64 bit running on a core a core i7 Laptop 8Gb memory connected to gigabit network. (Wired / Windows 7 Pro)

Switch GS716TV3 gigabit smart switch

Sound System - dCS Vivaldi upsampler connect to gigabit network.

NAS - QNAP TVS-1282T single gigabit connection running RAID 5 4 x 8TB (seagate ironwolf hard drives) with M.2 SSD RAID 0 2 x 256GB (Accelerated cache mode for ironwolf hard drives)

Local content - 156 tracks (AIFF 96kHz 24bit and FLAC 96kHz 24bit

We have tidal linked to the core which works perfectly but when we try an access local content we experience playback issues (sounds breaks up and hiccups continuously)

Any assistance will be appreciated (If you require my bosses account please let me know)

Kind Regards

Thank you for the detailed report, @Shaun_Ryzenberg!

In order to gain a little more insight into the issue, may I ask that you please verify the following:

  • Does this behavior occur for all zones? If, for example, you play to System Output on the client machine — Do you still experience this behavior?
  • Does this behavior happen with all tracks listed above? Just certain file types?
  • As mentioned in our Networking Guide, managed switches tend to require some advanced setup, and we have seen many issues stem the use of managed switches in the past. If your switch has a “flow control” setting, please make sure that it is enabled. Also, make sure that the switch is not performing any sort of throttling that might impact communication between cores, storage, remotes, and/or audio endpoints. Finally, ensure that the switch is configured to pass multicast and broadcast traffic. A great test to determine if the switch may be playing into the issue is to connect both the NAS and Core directly to the router and see if the behavior goes away.


Hi Dylan,

Thank you for the quick response.

It only affects when playing directly to the dCS Vivaldi upsampler.
It only affects all local content. Tidal play perfectly through the same network.

I will do some setting changes and give you more feedback. Unfortunately i’m not on site but can check remotely.

Kind Regards

Thanks for the update, @Shaun_Ryzenberg!

Since these files only have issues when playing to this particular device, the issue is likely stemming from the connection to this device. Can you describe how this device is connected to the network? Wired or wireless? A great test would be connecting the Core machine, this endpoint, and media storage directly to the router and seeing if this resolves the issue.


Hi Dylan,

I have enabled Flow Control and looks like the switch is configured to pass multicast and broadcast traffic.

Please can you look at attached screen shots to see if the settings look correct to you, unfortunately I have never done this before.Capture1Capture2

Hey @Shaun_Ryzenberg,

Yes, I believe that should be correct. Are you still experiencing the issue even after enabling flow control?

Hi Dylan,

I haven’t been onsite to do a physically test yet. Should be going on Wednesday to do a physical test.

But I need to give you more information.
We have complex network as we also run a business from my bosses house.
We have domain network with enterprise firewalls.

My bosses PC is the server (Core) which is a gigabit wired connection to un-managed switch (Located in the server room) which runs over a fiber gigabit connection to a managed switch (located in the entertainment room). From here there is another fiber gigabit connection to the GS716Tv3 switch (this is to isolate the media devices in the event of lightning etc as the value of this equipment runs into the millions). Now all media devices are connected to the GS716v3 such as the QNAP, the upsampler and the laptop which is the client. The only device which is not connected directly on the same switch is the server.

First question to you is if the flow control / network settings still give issues should I maybe move the Roon server to the QNAP? (Then all devices will be on the same switch GS716Tv3).

Second question is there a way to check the logs to see if there are any hiccups or dropouts without listening out for it?

Last question, when i’m on site tomorrow and i’m still not coming right is it possible to team view or assist me in fault finding? (My boss does have paid subscription for Roon and Tidal. Let me know if I must supply the details.)

I have enabled flow control on all the managed switches.

Kind Regards
Shaun Ryzenberg

Hi Dylan,

My boss has just contact me, unfortunately the flow control has not worked.
Will be going to site tomorrow and doing further test onsite.

Thank you again for all your help.


Thanks for the info, @Shaun_Ryzenberg!

That is worth a try, just keep our recommended specs in mind.

It might be possible, but can be very difficult without knowing what timestamps to reference. The logs keep track of many things and so searching through them for audio issues without knowing when it occurred can be very difficult and time consuming. The best option is listening for dropouts and referencing the logs if you notice one to see if you can get more information about what happened.

We do all of our support through the forums here, but if you have questions just let us know and we will be happy to assist!

Since it seems to be a pretty complex networking setup, here’s what I recommend — Connect everything to the main router first and make sure everything is working properly. Once you do this, you can start adding complexity and see where things break.

With the Core running through 3 different switches it can be pretty difficult to determine where the issue may be occurring. By simplifying as much as possible, and then rebuilding a piece at a time, you’ll be able to determine where the issue is coming from and that should make things easier to fix (i.e. one of the switches may not be configured properly and this will allow you to determine which one).

Our networking guide has some great information on managed switches and simplifying the network, so I’d definitely recommend checking that out.

If you have any questions as you are working on this just let us know!


Hi Dylan,

I am onsite now. I have isolated everything to only one switch GS716Tv3
I have also moved the Roon server to the QNAP. (QNAP has I7, 32gb memory)

It still does the same issue but only every 10 seconds now where previously it did it all the time.
I have downloaded the logs, please me know where i can send them.

Kind Regards
Shaun Ryzenberg

Hey @Shaun_Ryzenberg,

Thank you for the update!

Does this behavior happen for all endpoints still? If you play directly to the output on one of your remotes does it happen just the same as playing to the dCS endpoint?

For the logs, you can PM me a shared Dropbox link and I can get them to the technical team for analysis. Do you have timestamps for when the dropouts occurred?

Thank you,

Hi Dylan,

I have figured out the issue the DCS master clock was set to 44.1 I changed it to 48 and everything works. I think the issue is the local content is 96kHz 24 bit and cant play on 44.1 but it makes sense why Tidal was working because their content is 44.1 16bit.

Thank you again for the all the help. I have disabled flow control and moved the Roon server to the QNAP.

Kind Regards

1 Like