Issues with Allo USBridge

Newbie here that needs some help.

I ordered a Usbridge with Dietpi to use with Room and followed the starting guide on the Allo website and it seems like is connected and working properly (solid blue and blinking red on sparky, solid blue on Usbridge, solid orange with blinking green on network). I also connected my dragonfly red and try with and without HDMI cable connected but I cannot access the guide on browser, nor does the up address shows up on TV to try that out.

Y tried powering it with the 5v ps on Usbridge and dual ps (j28 pulled) and nothing. This is the first time using a small PC like this one and I just don’t know what to do next.

Any help will be greatly appreciated.

  1. Did you connect the DAC to the bottom USB port?

  2. Are you seeing a device in Setup - - - >Audio named “Diet Pi”?

  3. How are you connecting the USBridge to your Roon Server?


  1. yes it is connected to the bottom usb port.
  2. no I’m not
  3. I’m not sure I’m understanding this question 100%. haven’t been able to access dietpi gui nor detect dietpi on roon. So I guess I haven’t been able to connect it to roon server. Also Usbridge is connected by Ethernet to the Ethernet switch, server is on an iMac via WiFi on same network.

Thanks for taking the time to help!

Maybe you can post the Ip addresses of the core machine and the usbridge to be sure on the same network is indeed the case. Do you have any other endpoints on the same network (lan) that are working with roon? You maybe can get an app like FING to use on your mobile to see what it can see on your network.

I can see my IP address on iMac, not sure about the usbridge, I suppose it could be one of the two devices under the Shenzhen Zowee Technology that I don’t recognize… All three of them with the same IP address except for the last 2 digits…

To answer your other question I do see my other 4 end points connected to my network .

Any ideas? Is the software on the emmc card corrupted or not installed properly?

You should be able to enter the address into a browser to view the dietpi interface if you have the right address…just try them all maybe if you are not sure which is which.

For memory a usbridge has everything turned on so Roon Bridge should be running.

@andybob maybe this can be moved to a new thread and I’ll tag @ALLO_audio_boards too for you.

1 Like

One other option is you could PING the addresses to see if anything is alive on the devices you don’t recognise. do this from a terminal window…in spotlight type terminal and use that app. type ping [enter] or whatever the IP address is you want to check is responding.

I dont have my USBridge powered up right now but might go and do that to see what the device looks like

I really appreciate your help on this. I’ve already tried the two addresses that I don’t recognize and all I get is " this site can’t be reached, the IP address refuses to connect" message…

To login to mine the web UI is http://192.168.0.xx/allo/public/index.php you would need to use your IP address for that device…of course if you dont have the right device listed then maybe the unit is not in a state that is working

username is and password is allo

device is a CEM Solutions but that might be different to yours

http://192.168.0.xx:19999/#menu_system;theme=slate;help=true should get the netdata page

you might also need to login to the ssh connection…you do that from terminal app. but see how you go with web based first.

I’m going to log in to the web UI with several number combinations since I don’t know which one my USBRIDGE has. I have no idea on how to log in to the ssh connection or how to use the terminal app although I’m fairly good at figuring things out and I don’t mind doing it. If you could point me in the right direction for a step by step tutorial or similar I would really appreciate it; I’ve also contacted Allo through their website and hopefully they’ll chime in and help as well.

Thanks again for your help.

Let’s worry about the ssh once you have exhausted the current options

So I came back from work and decided to switch dac’s and it worked… The TV displayed the IP address and I was able to log in on Allo dietpi gui successfully. Now I see Roon being active on gui but Roon itself is not showing dietpi as an endpoint.

Any ideas?

So, while changing the settings I decided to try with a Static IP address which is now and now I can’t access the gui again… This is a little frustrating.

You will only see the dac in roon as an endpoint on the usbridge when the dac is on…and connected to Usb host port, otherwise roon won’t show anything at all

I think best to maybe wait for someone from @rahulkc_s Allo to drop in here and assist you.

There are updates to dietpi to a later version but when I did this it broke the netdata ui so let’s wait Allo support for now.

What dacs are you using and do you have them in the right USB ports…have you tried the non host ports?

I have a dragonfly red and a schiit modi 3. Right now I have the soundcard configured to usb dac 1.1 (for the dragonfly red). Also, I’ve only tried the bottom usb connection to the usbridge.

Do you know how I can display the correct IP address so I can access the gui or maybe change the IP address from Static back to dynamic using a keyboard? Maybe that will at least let me change the settings from the gui in the future.

in terminal type ssh root@ then dietpi is the password. if you can get that far see if you can get to change the IP address in the menus offered …

BUT if you mess it up then you might have to reinstall the dietpi image on the eMMC or SD card which ever you have.

What about just changing the network configuration back from Static to DHCP by typing a command on the terminal?
Is that possible?

When I had it as DHCP the Allo dietpi GUI was accessible and it’s not anymore.

Google software called advanced ip scanner. It is a free software that will scan all deviced on your network.
It is very good at resolving manufacturer name and device name.
If you haven’t changed name you should see a dietpi try above ssh instructions to that address.
Do you have a lcd tv or spare computer monitor with hdmi? Spare usb keyboard and mouse.